Modify

Opened 8 years ago

Closed 8 years ago

#7375 closed defect (fixed)

regression: Shortcut resetting not possible

Reported by: akks Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: shortcuts Cc:

Description (last modified by akks)

While working at #6239 I noticed some bug.

How to reproduce:

  • (Clean preferences for sure)
  • Change shortcut Shift-B (Distribute nodes) to Ctrl-Shift-B in F12
  • Restart JOSM
  • Check "Use default" checkbox for Distribute nodes, press OK
  • Restart JOSM
  • Look at shortcuts - Ctrl-Shift-B persists (preferences.xml too).

I thought it was my bug due to prefJPanel GUI code simplification, but it is reproducible since [4897]
(works for [4896], broken in [4897], [4900] helps to save user shortcuts but not reset it to defaut - not working for all later revisions).

After looking at the code I decided that I can not fix it myself.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by akks

Description: modified (diff)

comment:2 Changed 8 years ago by akks

Summary: regression:regression: Shortcut resetting not possible

comment:3 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

In 4916/josm:

fix #7375 - resetting shortcuts not possible

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.