Modify

Opened 8 years ago

Closed 8 years ago

#7358 closed defect (fixed)

regression: custom shortcuts are reverted to defaults upon restart

Reported by: Cobra Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: shortcuts Cc:

Description

It's not possible any more to set custom shortcuts.

The shortcut can be changed in the settings dialog and is still there when reopening it. But after restarting josm to use it, the custom shortcut is replaced by the default one.

This will definitely break the workflow for many users having set up their own shortcuts (which mostly the old ones you remembered, like alt-b for adding a tag), so I set this to critical. Sometimes this will have unforseen and unwanted consequences when you fire some other action instead of the intended one.

This will happen even with a blank preferences.xml.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4900/josm]:

fix #7358 - custom shortcuts broken

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.