Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7342 closed defect (duplicate)

Error while downloading using remote control

Reported by: mdk Owned by: team
Priority: normal Milestone:
Component: Core remotecontrol Version:
Keywords: Cc: michaelinredhill, seichter

Description (last modified by Don-vip)

While downloading a dublicate way from OSM InspectorI got this error twice. I don't know if it is a data problem, so I also add the current layer (see attachment)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-30 02:32:23
Last Changed Author: stoecker
Revision: 4878
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-30 00:02:54 +0100 (Mon, 30 Jan 2012)
Last Changed Rev: 4878

Identification: JOSM/1.5 (4878 en)
Memory Usage: 160 MB / 494 MB (80 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: ColumbusCSV (27432)
Plugin: OpeningHoursEditor (27355)
Plugin: RoadSigns (27289)
Plugin: SimplifyArea (27355)
Plugin: buildings_tools (27598)
Plugin: contourmerge (1003)
Plugin: download_along (27289)
Plugin: licensechange (27472)
Plugin: reltoolbox (27355)
Plugin: restart (27289)
Plugin: reverter (27604)
Plugin: tageditor (27576)
Plugin: terracer (27289)
Plugin: turnlanes (27355)
Plugin: turnrestrictions (27355)
Plugin: undelete (27395)
Plugin: utilsplugin2 (27624)
Plugin: waydownloader (27289)

java.lang.IndexOutOfBoundsException: Index: 33, Size: 2
	at java.util.ArrayList.rangeCheck(ArrayList.java:571)
	at java.util.ArrayList.get(ArrayList.java:349)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.getElementAt(RelationListDialog.java:701)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1359)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1310)
	at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2619)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:184)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:164)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:211)
	at javax.swing.DefaultListSelectionModel.insertIndexInterval(DefaultListSelectionModel.java:632)
	at javax.swing.plaf.basic.BasicListUI$Handler.intervalAdded(BasicListUI.java:2577)
	at javax.swing.AbstractListModel.fireIntervalAdded(AbstractListModel.java:147)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.setRelations(RelationListDialog.java:619)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.initFromLayer(RelationListDialog.java:175)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.dataChanged(RelationListDialog.java:870)
	at org.openstreetmap.josm.io.remotecontrol.handler.LoadAndZoomHandler$2.run(LoadAndZoomHandler.java:178)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)

Attachments (3)

currentData.osm (981.8 KB) - added by mdk 8 years ago.
josm_osmi_exception.png (95.5 KB) - added by Don-vip 8 years ago.
data#7342_with_r5022.osm (215.6 KB) - added by Don-vip 8 years ago.

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by mdk

Attachment: currentData.osm added

comment:1 Changed 8 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In [4884/josm]:

fix #7342 - IndexOutOfBoundsException while using remote control

comment:3 Changed 8 years ago by Don-vip

Resolution: fixed
Status: closedreopened

Just got this error again with r5022 while downloading a way from OSM Inspector:


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-02-24 02:32:27
Last Changed Author: Don-vip
Revision: 5022
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-02-23 22:17:50 +0100 (Thu, 23 Feb 2012)
Last Changed Rev: 5022

Identification: JOSM/1.5 (5022 en)
Memory Usage: 183 MB / 3729 MB (42 MB allocated, but free)
Java version: 1.7.0_02, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: PicLayer (27883)
Plugin: cadastre-fr (27906)
Plugin: dataimport (27289)
Plugin: epci-fr (26960)
Plugin: imagery-xml-bounds (27921)
Plugin: licensechange (27888)
Plugin: mirrored_download (27906)
Plugin: opendata (303)
Plugin: pbf (27649)
Plugin: print (27865)
Plugin: proj4j (27902)
Plugin: public_transport (27886)
Plugin: restart (27852)
Plugin: tag2link (27857)
Plugin: utilsplugin2 (27865)

java.lang.IndexOutOfBoundsException: Index: 0, Size: 1
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.getElementAt(RelationListDialog.java:709)
	at javax.swing.plaf.basic.BasicListUI.paintCell(Unknown Source)
	at javax.swing.plaf.basic.BasicListUI.paintImpl(Unknown Source)
	at javax.swing.plaf.basic.BasicListUI.paint(Unknown Source)
	at javax.swing.plaf.ComponentUI.update(Unknown Source)
	at javax.swing.JComponent.paintComponent(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$700(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Changed 8 years ago by Don-vip

Attachment: josm_osmi_exception.png added

Changed 8 years ago by Don-vip

Attachment: data#7342_with_r5022.osm added

comment:4 Changed 8 years ago by Don-vip

Ticket #7452 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by simon04

Unfortunately, I cannot reproduce using Java version: 1.7.0_03-icedtea, Oracle Corporation, OpenJDK 64-Bit Server VM (OpenJDK). Can you please give me some additional hints?

Remark: The remote command copied from the cmd window is http://127.0.0.1:8111/load_and_zoom?left=1.56976&bottom=43.79191&right=1.57900&top=43.79540&select=way22663172

comment:6 Changed 8 years ago by simon04

Component: CoreCore remotecontrol

comment:7 Changed 8 years ago by hfs

I got the same exception several times when using the remote control link from “keep right!”.

Debian-Release: 0.0.svn4878+dfsg1-1
Build-Date: 2012-02-02 10:42:47
Revision: 4878
Is-Local-Build: true

Identification: JOSM/1.5 (4878 de)
Memory Usage: 330 MB / 1745 MB (196 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectDownload (27649)
Plugin: DirectUpload (27679)
Plugin: buildings_tools (27676)
Plugin: dataimport (27289)
Plugin: editgpx (27679)
Plugin: mapdust (27596)
Plugin: openstreetbugs (27355)
Plugin: plastic_laf (26605)
Plugin: public_transport (27676)
Plugin: restart (27649)
Plugin: routes (27355)
Plugin: terracer (27649)

java.lang.IndexOutOfBoundsException: Index: 52, Size: 6
	at java.util.ArrayList.rangeCheck(ArrayList.java:571)
	at java.util.ArrayList.get(ArrayList.java:349)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.getElementAt(RelationListDialog.java:701)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1359)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1310)
	at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2619)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:184)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:164)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:211)
	at javax.swing.DefaultListSelectionModel.insertIndexInterval(DefaultListSelectionModel.java:632)
	at javax.swing.plaf.basic.BasicListUI$Handler.intervalAdded(BasicListUI.java:2577)
	at javax.swing.AbstractListModel.fireIntervalAdded(AbstractListModel.java:147)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.setRelations(RelationListDialog.java:619)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.initFromLayer(RelationListDialog.java:175)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.dataChanged(RelationListDialog.java:870)
	at org.openstreetmap.josm.data.osm.event.DataChangedEvent.fire(DataChangedEvent.java:26)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.fireEvents(DatasetEventManager.java:109)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.access$200(DatasetEventManager.java:27)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager$1.run(DatasetEventManager.java:139)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1551)
	at java.awt.Component.setVisible(Component.java:1503)
	at java.awt.Window.setVisible(Window.java:881)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:170)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

comment:8 in reply to:  7 Changed 8 years ago by simon04

Replying to hfs:

I got the same exception several times when using the remote control link from “keep right!”.

Revision: 4878

Please make sure to use a recent version. Some changes have been made in r4884.

comment:9 Changed 8 years ago by Don-vip

Ticket #7645 has been marked as a duplicate of this ticket.

comment:10 Changed 8 years ago by Don-vip

Cc: michaelinredhill added

comment:11 Changed 8 years ago by Don-vip

Ticket #7782 has been marked as a duplicate of this ticket.

comment:12 Changed 8 years ago by Don-vip

Cc: seichter added

comment:13 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #8083.
Fixed in r5517.

Last edited 7 years ago by Don-vip (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.