Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7337 closed defect (duplicate)

Je ne peux plus travailler sur l'éditeur Java Openstreet Map, le méssage d'erreur s'affiche systématiquement

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

Je ne peux plus travailler sur l'éditeur Java Openstreet Map, le méssage d'erreur s'affiche systématiquement.
Je passe un temps fou, pour un résultat nul.
Je crains de devoir abandonner cet outil qui semblait si prometteur.

Frédéric de Flaugergues

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-19 02:32:42
Last Changed Author: Don-vip
Revision: 4667
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-19 00:02:30 +0100 (Mon, 19 Dec 2011)
Last Changed Rev: 4667

Identification: JOSM/1.5 (4667 fr)
Memory Usage: 169 MB / 494 MB (84 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=42207707 version=7 MVT nodes=[]} has zero nodes


Plugin: Tracer (27354)
Plugin: cadastre-fr (27484)
Plugin: openstreetbugs (27355)
Plugin: turnrestrictions (27355)

java.lang.IndexOutOfBoundsException: Index:0 Size:0
	at org.openstreetmap.josm.tools.CopyList.rangeCheck(CopyList.java:132)
	at org.openstreetmap.josm.tools.CopyList.get(CopyList.java:59)
	at org.openstreetmap.josm.data.validation.tests.MultipolygonTest.visit(MultipolygonTest.java:123)
	at org.openstreetmap.josm.data.osm.Way.visit(Way.java:162)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:139)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:60)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:137)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:160)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:203)
	at javax.swi

Attachments (0)

Change History (3)

comment:1 in reply to:  description Changed 10 years ago by bastiK

Replying to anonymous:

Je ne peux plus travailler sur l'éditeur Java Openstreet Map, le méssage d'erreur s'affiche systématiquement.

Thanks for reporting the problem. The fact that this error comes always is good, because it allows us to fix the problem. Just save and attach the osm file.

@team: way with 0 nodes

Je passe un temps fou, pour un résultat nul.

Save your work before upload and it won't be lost.

Je crains de devoir abandonner cet outil qui semblait si prometteur.

Sure, good luck then.

comment:2 Changed 10 years ago by skyper

Resolution: duplicate
Status: newclosed

Please try new tested version !

comment:3 Changed 10 years ago by skyper

Closed as duplicate of #7160.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.