Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7315 closed defect (fixed)

Join node cursor problems with Ctrl

Reported by: joshdoe Owned by: team
Priority: minor Milestone:
Component: Core Version:
Keywords: join node cursor Cc:

Description

The join node cursor image doesn't always show properly. It seems to only show while moving the cursor, but not while stationary, causing a blinking effect. Additionally while moving a way the join node cursor image is shown if the pointer is near a way while Ctrl is held down.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by xeen

I can confirm both issues. Steps to reproduce are:

  1. create two single nodes
  2. grab&drag one onto the other
  3. press ctrl

→ merge to node cursor not shown

  1. create a way and a unconnected node
  2. grab way on way-part (i.e. none of its nodes; not a virtual node)
  3. drag way so that the cursor is hovering the node while pressing ctrl

→ merge to node cursor is shown

comment:2 Changed 8 years ago by xeen

I likely have a fix for the first issue, but I’m unsure about the second. Merging only works for nodes, so if the selection only contains ways there shouldn’t even be a merge cursor (the cross) because the merge can’t possibly find a valid target. Unless someone has a better suggestion, I’m going with disabling the merge cursor in this case altogether.

comment:3 Changed 8 years ago by xeen

Resolution: fixed
Status: newclosed

In 4934/josm:

likely fix #7315’s cursor issues and related target-highlight ones

comment:4 Changed 8 years ago by xeen

Please reopen the ticket if the fixes do not work for you.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.