Modify

Opened 12 years ago

Closed 12 years ago

#7305 closed defect (fixed)

Upload failed for big changeset

Reported by: pierre.quenee@… Owned by: bastiK
Priority: critical Milestone:
Component: Core Version: latest
Keywords: upload Cc:

Description (last modified by skyper)

In :

Identification: JOSM/1.5 (4857 fr)

a big changeset (10 x 500) failed with Read time error :

PUT http://api.openstreetmap.org/api/0.6/changeset/create... OK
POST http://api.openstreetmap.org/api/0.6/changeset/10473575/upload...
POST http://api.openstreetmap.org/api/0.6/changeset/10473575/upload...
POST http://api.openstreetmap.org/api/0.6/changeset/10473575/upload...
POST http://api.openstreetmap.org/api/0.6/changeset/10473575/upload...
POST http://api.openstreetmap.org/api/0.6/changeset/10473575/upload...
POST http://api.openstreetmap.org/api/0.6/changeset/10473575/upload...
org.openstreetmap.josm.io.OsmTransferException: java.net.SocketTimeoutException: Read timed out
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:665)
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:534)
        at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:484)
        at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesInChunks(OsmServerWriter.java:172)
        at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:214)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:233)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:137)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.net.SocketTimeoutException: Read timed out
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.io.BufferedInputStream.fill(Unknown Source)
        at java.io.BufferedInputStream.read1(Unknown Source)
        at java.io.BufferedInputStream.read(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
        at java.net.HttpURLConnection.getResponseCode(Unknown Source)
        at java.net.HttpURLConnection.getResponseMessage(Unknown Source)
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:596)
        ... 10 more

With version r4842 the same data are upload fine.

Attachments (1)

4857 - 4842 JOSM.txt (71.7 KB ) - added by pierre.quenee@… 12 years ago.
State of 4857 and 4842 + historic of upload

Download all attachments as: .zip

Change History (8)

by pierre.quenee@…, 12 years ago

Attachment: 4857 - 4842 JOSM.txt added

State of 4857 and 4842 + historic of upload

comment:1 by skyper, 12 years ago

Description: modified (diff)

format

comment:2 by stoecker, 12 years ago

Resolution: worksforme
Status: newclosed

Timeout means that connection was broken or delayed too much. Either network or server issues. Also this is self-healing.

in reply to:  2 comment:3 by anonymous, 12 years ago

Replying to stoecker:

Timeout means that connection was broken or delayed too much. Either network or server issues. Also this is self-healing.

Ok, I will edit with 4857. When the upload will crash, I record the data, and I will upload with 4842 ... till the "self-healing" bug disappear .

comment:4 by stoecker, 12 years ago

Resolution: worksforme
Status: closedreopened

comment:5 by stoecker, 12 years ago

Owner: changed from team to bastiK
Status: reopenednew

@bastiK:

You changed OsmAPI-Read-Timout. In case API processes data, the 15 seconds are probably too low. So for data upload (and download?) we need another timeout in the order of minutes.

comment:6 by bastiK, 12 years ago

In [4859/josm]:

no read timeout for normal API connections (see #6823, see #7305)

comment:7 by stoecker, 12 years ago

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.