Modify

Opened 8 years ago

Closed 8 years ago

#7291 closed defect (fixed)

Can't use WMS layer in 4818

Reported by: jezevec Owned by: jezevec
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc: jttt

Description (last modified by skyper)

Josm report bug after wms use attempt (I test few different sources)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-19 02:33:08
Last Changed Author: bastiK
Revision: 4818
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-18 20:43:48 +0100 (Wed, 18 Jan 2012)
Last Changed Rev: 4818

Identification: JOSM/1.5 (4818 cs)
Memory Usage: 151 MB / 989 MB (70 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows Vista
Dataset consistency test: No problems found

Plugin: ElevationProfile (27285)
Plugin: Tracer (27354)
Plugin: buildings_tools (27355)
Plugin: download_along (27289)
Plugin: licensechange (27472)
Plugin: measurement (27289)
Plugin: multipoly-convert (27289)
Plugin: openstreetbugs (27355)
Plugin: plastic_laf (26605)
Plugin: reverter (27393)
Plugin: turnrestrictions (27355)
Plugin: undelete (27395)
Plugin: utilsplugin2 (27426)
Plugin: waydownloader (27289)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.imagery.WmsCache.removeNonReferencedFiles(WmsCache.java:246)
	at org.openstreetmap.josm.data.imagery.WmsCache.loadIndex(WmsCache.java:219)
	at org.openstreetmap.josm.gui.layer.WMSLayer.<init>(WMSLayer.java:173)
	at org.openstreetmap.josm.gui.layer.ImageryLayer.create(ImageryLayer.java:133)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:45)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (20)

comment:1 Changed 8 years ago by skyper

Description: modified (diff)

layout

comment:2 Changed 8 years ago by jttt

Cc: jttt added

I don't get NPE, but wms cache is now in different directory and old cache is not moved. It would be shame to loose all that cached tiles...

comment:3 Changed 8 years ago by jezevec

I change only josm from prev version, I test remove all cached files and same error. With integrated bing sat, I have backround with "Error:null".

On another PC I have 4806, and there no problem with this. So it must be somewhere in few lates changes.

comment:4 in reply to:  2 Changed 8 years ago by rickmastfan67

Replying to jttt:

I don't get NPE, but wms cache is now in different directory and old cache is not moved. It would be shame to loose all that cached tiles...

I'm getting it. Try using the following imagery source:

Terraserver Topo: wms:http://terraservice.net/ogcmap.ashx?version=1.1.1&request=GetMap&Layers=drg&styles=&format=image/jpeg&SRS={proj}&WIDTH={width}&height={height}&BBOX={bbox}

This service last worked with r4806. But in r4818 and later, I'm getting a NPE when trying to access it.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-20 02:31:17
Last Changed Author: bastiK
Revision: 4824
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-19 23:11:52 +0100 (Thu, 19 Jan 2012)
Last Changed Rev: 4824

Identification: JOSM/1.5 (4824 en)
Memory Usage: 152 MB / 2730 MB (99 MB allocated, but free)
Java version: 1.6.0_30, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (27355)
Plugin: buildings_tools (27355)
Plugin: imageryadjust (27355)
Plugin: licensechange (27472)
Plugin: mapdust (27355)
Plugin: measurement (27289)
Plugin: openstreetbugs (27355)
Plugin: restart (27289)
Plugin: reverter (27393)
Plugin: turnrestrictions (27355)
Plugin: undelete (27395)
Plugin: utilsplugin2 (27426)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.imagery.WmsCache.removeNonReferencedFiles(WmsCache.java:246)
	at org.openstreetmap.josm.data.imagery.WmsCache.loadIndex(WmsCache.java:219)
	at org.openstreetmap.josm.gui.layer.WMSLayer.<init>(WMSLayer.java:173)
	at org.openstreetmap.josm.gui.layer.ImageryLayer.create(ImageryLayer.java:133)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:45)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:5 Changed 8 years ago by simon04

I cannot reproduce. Please try with a clean JOSM setting dir.

comment:6 in reply to:  5 Changed 8 years ago by rickmastfan67

Replying to simon04:

I cannot reproduce. Please try with a clean JOSM setting dir.

Just did. Still happened.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-20 02:31:17
Last Changed Author: bastiK
Revision: 4824
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-19 23:11:52 +0100 (Thu, 19 Jan 2012)
Last Changed Rev: 4824

Identification: JOSM/1.5 (4824 en)
Memory Usage: 157 MB / 2730 MB (57 MB allocated, but free)
Java version: 1.6.0_30, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found


java.lang.NullPointerException
	at org.openstreetmap.josm.data.imagery.WmsCache.removeNonReferencedFiles(WmsCache.java:246)
	at org.openstreetmap.josm.data.imagery.WmsCache.loadIndex(WmsCache.java:219)
	at org.openstreetmap.josm.gui.layer.WMSLayer.<init>(WMSLayer.java:173)
	at org.openstreetmap.josm.gui.layer.ImageryLayer.create(ImageryLayer.java:133)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:45)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:7 Changed 8 years ago by akks

Ticket #7292 has been marked as a duplicate of this ticket.

comment:9 Changed 8 years ago by landwirt@…

At least for the WMS cache the solution may lay in the WmsCache.java function cacheDirPath(). On Windows it creates a cPath like "C:\Cache\C:\Cache\wms" because the condition cPath.startsWith(":/",1) doesn't work. With cPath.startsWith(":
",1) the cache works fine.

comment:10 in reply to:  9 Changed 8 years ago by landwirt@…

Replying to landwirt@…:

At least for the WMS cache the solution may lay in the WmsCache.java function cacheDirPath(). On Windows it creates a cPath like "C:\Cache\C:\Cache\wms" because the condition cPath.startsWith(":/",1) doesn't work. With cPath.startsWith(":
",1) the cache works fine.

cPath.startsWith(":\\",1)

comment:11 Changed 8 years ago by bastiK

Resolution: fixed
Status: newclosed

In [4829/josm]:

fixed #7291 - Can't use WMS layer in 4818

comment:12 in reply to:  9 Changed 8 years ago by bastiK

Replying to landwirt@…:

At least for the WMS cache the solution may lay in the WmsCache.java function cacheDirPath(). On Windows it creates a cPath like "C:\Cache\C:\Cache\wms" because the condition cPath.startsWith(":/",1) doesn't work. With cPath.startsWith(":
",1) the cache works fine.

Thanks, fixed this - should work now.

comment:13 Changed 8 years ago by akks

Ticket #7304 has been marked as a duplicate of this ticket.

comment:14 Changed 8 years ago by navmaps_eu

Resolution: fixedinvalid

Nice to close the ticket, but as a non-expert I don't know how to apply the solution. Still this same problem with error:null using Bing imagery on version 4863. I have to stick to the old working 4808

comment:15 Changed 8 years ago by navmaps_eu

Resolution: invalid
Status: closedreopened

Ticket should be open again, can't get Bing running (no problems with other WMS layers, only Bing)

comment:16 in reply to:  14 Changed 8 years ago by simon04

Replying to navmaps_eu:

Nice to close the ticket, but as a non-expert I don't know how to apply the solution. Still this same problem with error:null using Bing imagery on version 4863. I have to stick to the old working 4808

Any error messages printed on the konsole? Does the error occur when testing with a clean settings directory?

comment:17 Changed 8 years ago by navmaps_eu

In the bottom left I see the usual 'Bing, Background terms of use'. However, in the bottom right I see: 'Error loading Bing attribution data'. I completely cleared the cache (deletion of the folder Bing Aerial Maps). Tested with two other WMS layers: ODBL coverage and Mapquest OSM. These two work just fine.

comment:18 Changed 8 years ago by simon04

Please test with after resetting all settings (see Help/ResetPreferences, backup your current directory).

Is any error printed to the command line (Windows: run cmd, execute java -jar path\to\josm-latest.jar after replacing path\to accordingly)?

comment:19 Changed 8 years ago by skyper

Owner: changed from team to jezevec
Status: reopenedneedinfo

I have deleted duplicated comments.

You probably need to delete/move out of the way not just the preferences dir but also the cache dir.

comment:20 Changed 8 years ago by navmaps_eu

I already deleted the cache which didn't help. Deleting the preferences.xml file in my case did the trick, the Bing images are showing up again in JOSM. Thanks!

comment:21 Changed 8 years ago by simon04

Resolution: fixed
Status: needinfoclosed

:-). So let's close this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jezevec.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.