Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7247 closed defect (fixed)

Error import GPX

Reported by: berezin_geo@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: gpx import Cc:

Description

I'm used DNR-Garmin (v5.4.1) soft for creating GPX-file.

If importing (opening) this file in JOSM (v.4667) NOT open and appear error message "...error in syntax parsing file XXX.gpx. Will be opening part file..."

Version GPX from DNR-1.0. Else converting to version 1.1 file correct open in JOSM.

Attachments (1)

kir_tr012012_from DNR.gpx (176.0 KB) - added by berezin_geo@… 8 years ago.
gpx-file from DNR-Garmin

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by berezin_geo@…

Attachment: kir_tr012012_from DNR.gpx added

gpx-file from DNR-Garmin

comment:1 Changed 8 years ago by stoecker

Reason is that there are <gpxx:depth> and <gpxx:temperature> fields and they are rejected due to namespace conflicts. xmllint says namespace error : Namespace prefix gpxx on depth is not defined.

This should not be handled as error, but asd warning inside JOSM.

Workaround: Replace gpxx: in the file by gpxx_.

comment:2 Changed 8 years ago by Gnonthgol

Would setting the parser to non namespace aware break anything? As far as I see we disregard the namespace anyway. Just change /src/org/openstreetmap/josm/io/GpxReader.java:369 to false.

comment:3 Changed 8 years ago by bastiK

Resolution: fixed
Status: newclosed

In [4808/josm]:

fixed #7247 - Error import GPX

comment:4 Changed 8 years ago by bastiK

Ok, let's try this.

comment:5 Changed 7 years ago by bastiK

In 5679/josm:

fixed #2900 - Saving and reopening of downloaded gpx segments displays distorted data (see #7247; namespace aware xml parsing is needed now, so #7247 is open again)

comment:6 Changed 7 years ago by bastiK

The problem is back again, but I leave it closed as othersoftware / wontfix.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.