Modify

Opened 8 years ago

Closed 8 years ago

#7218 closed defect (fixed)

NPE after download with waydownloader

Reported by: skyper Owned by: jttt
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report waydownloader NPE Cc:

Description

Do not know if this belongs to Core or waydownloader but it seems to me that waydownloader needs an update.

What steps will reproduce the problem?

  1. download a way which ends at a T-intersection and select it
  2. use waydownloader
  3. download works and you get a warning about the T-intersection
  4. choose "OK"

What is the expected result?

Nothing

What happens instead?

Exception

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-31 02:31:54
Last Changed Author: bastiK
Revision: 4755
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-30 23:40:55 +0100 (Fri, 30 Dec 2011)
Last Changed Rev: 4755

Identification: JOSM/1.5 (4755 de)
Memory Usage: 50 MB / 248 MB (1 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: waydownloader (27289)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$10.run(PleaseWaitProgressMonitor.java:269)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$2.run(EventQueue.java:622)
	at java.awt.EventQueue$2.run(EventQueue.java:620)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1492)
	at java.awt.Component.setVisible(Component.java:1444)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:163)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138

Happens without any connected way, too :

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-31 02:31:54
Last Changed Author: bastiK
Revision: 4755
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-30 23:40:55 +0100 (Fri, 30 Dec 2011)
Last Changed Rev: 4755

Identification: JOSM/1.5 (4755 de)
Memory Usage: 63 MB / 508 MB (8 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: waydownloader (27289)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$10.run(PleaseWaitProgressMonitor.java:269)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by rickmastfan67

Pretty sure this is a duplicate of #7211.

Plus I would update Java if I were you. It's @ 1.6.0_30 now, and you're running 1.6.0_18.

comment:2 in reply to:  1 Changed 8 years ago by skyper

Replying to rickmastfan67:

Pretty sure this is a duplicate of #7211.

No it is not:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-02 02:32:19
Last Changed Author: stoecker
Revision: 4759
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-01 22:17:05 +0100 (Sun, 01 Jan 2012)
Last Changed Rev: 4759

Identification: JOSM/1.5 (4759 de)
Memory Usage: 45 MB / 248 MB (14 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: waydownloader (27289)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$10.run(PleaseWaitProgressMonitor.java:276)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Plus I would update Java if I were you. It's @ 1.6.0_30 now, and you're running 1.6.0_18.

This is a debian stable machine.

comment:3 Changed 8 years ago by rickmastfan67

Component: PluginCore

Just triggered it myself. However, I don't think it's a bug with that plugin. Per the bug report, it has something to do with the Progress bar, which is what was the NPE error in #7211. However, this one is triggering the NPE in a different place, but in the same file.

So, I'll change the component to "Core".

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-02 02:32:19
Last Changed Author: stoecker
Revision: 4759
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-01 22:17:05 +0100 (Sun, 01 Jan 2012)
Last Changed Rev: 4759

Identification: JOSM/1.5 (4759 en)
Memory Usage: 155 MB / 2730 MB (83 MB allocated, but free)
Java version: 1.6.0_30, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (27355)
Plugin: buildings_tools (27355)
Plugin: imageryadjust (27355)
Plugin: licensechange (27359)
Plugin: mapdust (27355)
Plugin: measurement (27289)
Plugin: openstreetbugs (27355)
Plugin: restart (27289)
Plugin: reverter (27393)
Plugin: turnlanes (27355)
Plugin: turnrestrictions (27355)
Plugin: undelete (27395)
Plugin: utilsplugin2 (27355)
Plugin: waydownloader (27289)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$10.run(PleaseWaitProgressMonitor.java:276)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:4 Changed 8 years ago by jttt

Owner: changed from team to jttt

comment:5 Changed 8 years ago by jttt

close() method is called twice, simple dialog != null check will fix this. But first I'll check why is there public close() method, closing should be done in doFinishTask().

comment:6 Changed 8 years ago by jttt

Resolution: fixed
Status: newclosed

In [4761/josm]:

Fix #7218 NPE after download with waydownloader

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.