Modify

Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#7210 closed defect (duplicate)

error loading preferences

Reported by: wolfgang@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Since today josm is no longer loading its preferences at startup for me, giving this error messages:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-19 02:32:42
Last Changed Author: Don-vip
Revision: 4667
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-19 00:02:30 +0100 (Mon, 19 Dec 2011)
Last Changed Rev: 4667

FEHLER:
java.lang.NullPointerException

at com.sun.org.apache.xerces.internal.jaxp.validation.StAXValidatorHelper.validate(StAXValidatorHelper.java:95)
at com.sun.org.apache.xerces.internal.jaxp.validation.ValidatorImpl.validate(ValidatorImpl.java:114)
at javax.xml.validation.Validator.validate(Validator.java:127)
at org.openstreetmap.josm.data.Preferences.validateXML(Preferences.java:1436)
at org.openstreetmap.josm.data.Preferences.load(Preferences.java:580)
at org.openstreetmap.josm.data.Preferences.load(Preferences.java:542)
at org.openstreetmap.josm.data.Preferences.init(Preferences.java:678)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:190)

GET http://api.openstreetmap.org/api/capabilities... OK
Kommunikation mit http://api.openstreetmap.org/api mittels Protokollversion 0.6 etabliert.

If I end josm now and start it again I get the same error, so josm is also not able to read the newly created preferences file. I already removed my .josm folder which did not change anything.
The two things I have changed recently:

  • rebuild java with new timezone config
  • updated to josm 4667

System information:
$ uname -a
FreeBSD vulcan.lyxys.ka.sub.org 8.2-STABLE FreeBSD 8.2-STABLE #19: Sat Dec 24 09:23:02 CET 2011 wolfgang@…:/usr/obj/usr/src/sys/GENERIC amd64

$ java -version
java version "1.6.0_03-p4"
Java(TM) SE Runtime Environment (build 1.6.0_03-p4-wolfgang_25_dec_2011_15_57-b00)
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_03-p4-wolfgang_25_dec_2011_15_57-b00, mixed mode)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

Java bug, see Help/SystemRequirements, update Java.

comment:2 Changed 10 years ago by stoecker

Closed as duplicate of #7206.

comment:3 Changed 10 years ago by stoecker

Ticket #7227 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.