Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7168 closed enhancement (fixed)

Add a "jump to gap" functionality to the relation editor

Reported by: hwb Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: relation editor Cc: malenki, scai

Description

When fixing larger (route-)relations it would be very helpful if there were buttons within the relation editor for jumping to the next or previous gap in the graph.

Scrolling through the included ways consumes time and there is a high risk for missing gaps.

Attachments (1)

7168.patch (6.9 KB) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by malenki

Cc: malenki added

I second this enhancement. Having longed for such a tool quite some time, but was too busy to open a ticket myself.

comment:2 Changed 8 years ago by scai

Cc: scai added

Sounds like a great idea for fixing large relations without additional tools, +1.

Changed 8 years ago by simon04

Attachment: 7168.patch added

comment:3 Changed 8 years ago by simon04

Summary: Add a "jump to gap" functionality to the relation editor[Patch] Add a "jump to gap" functionality to the relation editor

Patch adds context menu entry.

comment:4 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In [4792/josm]:

fix #7168 - add a "zoom to gap" functionality to the relation editor

comment:5 Changed 8 years ago by hwb <holbi@…>

Resolution: fixed
Status: closedreopened

Hi simon04,

thank you for working on my feature suggestion! Unfortunately I obviously didn't describe it very well as you didn't get my point.

What I had in mind were buttons within the relation editor which allow to jump to a gap in the relation members list on the left. This would be a great help for locating the gap within the relation graph, zooming on adjacent elements in the main window for fixing the error would be the next step. So what you have implemented is helpful, too, but what really would make life easier comes one step earlier.

comment:6 in reply to:  5 Changed 8 years ago by skyper

Replying to holbi@…:

Hi simon04,

thank you for working on my feature suggestion! Unfortunately I obviously didn't describe it very well as you didn't get my point.

What I had in mind were buttons within the relation editor which allow to jump to a gap in the relation members list on the left. This would be a great help for locating the gap within the relation graph, zooming on adjacent elements in the main window for fixing the error would be the next step. So what you have implemented is helpful, too, but what really would make life easier comes one step earlier.

I think you will only need on of these two options.

Please, do not add to many buttons to the relation editor - or let they be hidable and configurable.
I already have problems on small screens with the last changes.

Thanks.

comment:7 Changed 8 years ago by simon04

Summary: [Patch] Add a "jump to gap" functionality to the relation editorAdd a "jump to gap" functionality to the relation editor

comment:8 Changed 8 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 5081/josm:

fix #7168 - add "Select previous/next Gap" to relation editor as popup menu of the relation members

comment:9 Changed 8 years ago by simon04

Ticket #5874 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.