Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7149 closed defect (duplicate)

Crash upon changing to way-extension mode and trying to extend newly created road

Reported by: post@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description (last modified by dittaeva)

This happened twice, I've just imported a gpx, converted it to a data layar, simplified the imported way, merged with data layer with OSM data, and want to remove a point from the way. It crashes upon me clicking on the the first point on the way.

Error dump from JOSM:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-10-31 02:32:25
Last Changed Author: stoecker
Revision: 4550
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-10-30 22:19:50 +0100 (Sun, 30 Oct 2011)
Last Changed Rev: 4550

Identification: JOSM/1.5 (4550 en)
Memory Usage: 106 MB / 1344 MB (29 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., OpenJDK Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectUpload (26849)
Plugin: ElevationProfile (26946)
Plugin: ImageWayPoint (26762)
Plugin: InfoMode (26986)
Plugin: buildings_tools (26731)
Plugin: dataimport (26731)
Plugin: measurement (26731)
Plugin: reverter (27091)
Plugin: undelete (26928)
Plugin: waydownloader (26986)
Plugin: waypoint_search (26986)

java.lang.ArrayIndexOutOfBoundsException: 0

at org.openstreetmap.josm.data.osm.Way.getNode(Way.java:113)
at org.openstreetmap.josm.actions.mapmode.DrawAction.computeHelperLine(DrawAction.java:695)
at org.openstreetmap.josm.actions.mapmode.DrawAction.selectionChanged(DrawAction.java:230)
at org.openstreetmap.josm.data.osm.DataSet.fireSelectionChanged(DataSet.java:433)
at org.openstreetmap.josm.data.UndoRedoHandler.afterAdd(UndoRedoHandler.java:51)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:59)
at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:149)
at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:28)
at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1660)
at javax.swing.JComponent.processKeyBinding(JComponent.java:2851)
at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:285)
at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:247)
at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2928)
at javax.swing.JComponent.processKeyBindings(JComponent.java:2920)
at javax.swing.JComponent.processKeyEvent(JComponent.java:2814)
at java.awt.Component.processEvent(Component.java:6045)
at java.awt.Container.processEvent(Container.java:2045)
at java.awt.Component.dispatchEventImpl(Component.java:4629)
at java.awt.Container.dispatchEventImpl(Container.java:2103)
at java.awt.Component.dispatchEvent(Component.java:4455)
at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1881)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:759)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1035)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:902)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:724)
at java.awt.Component.dispatchEventImpl(Component.java:4499)
at java.awt.Container.dispatchEventImpl(Container.java:2103)
at java.awt.Window.dispatchEventImpl(Window.java:2517)
at java.awt.Component.dispatchEvent(Component.java:4455)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
at java.awt.EventQueue.access$000(EventQueue.java:96)
at java.awt.EventQueue$1.run(EventQueue.java:608)
at java.awt.EventQueue$1.run(EventQueue.java:606)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
at java.awt.EventQueue$2.run(EventQueue.java:622)
at java.awt.EventQueue$2.run(EventQueue.java:620)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by dittaeva

Description: modified (diff)
Summary: Crash upon changing to way-extension mode and clicking close to to pointsCrash upon changing to way-extension mode and trying to extend newly created road

comment:2 Changed 10 years ago by bastiK

Please attach the gpx file and try to make this error reproducible.

comment:3 Changed 10 years ago by Don-vip

Resolution: duplicate
Status: newclosed

comment:4 Changed 10 years ago by Don-vip

Closed as duplicate of #7118.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.