Modify

Opened 10 years ago

Closed 10 years ago

#7088 closed defect (fixed)

Preferences NullPointerException

Reported by: anonymous Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. F12
  2. Click on Plugin icon
  3. Crash
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-11-27 02:32:27
Last Changed Author: bastiK
Revision: 4613
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-11-26 21:53:31 +0100 (Sat, 26 Nov 2011)
Last Changed Rev: 4613

Identification: JOSM/1.5 (4613 de)
Memory Usage: 361 MB / 762 MB (296 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Plugin: ImportImagePlugin (26986)
Plugin: OpeningHoursEditor (26986)
Plugin: PicLayer (27152)
Plugin: RoadSigns (26731)
Plugin: alignways (26986)
Plugin: buildings_tools (26731)
Plugin: graphview (26986)
Plugin: licensechange (26986)
Plugin: mapdust (26731)
Plugin: multipoly-convert (26928)
Plugin: openstreetbugs (26986)
Plugin: public_transport (26986)
Plugin: reverter (27091)
Plugin: tageditor (26986)
Plugin: turnrestrictions (26986)
Plugin: undelete (26928)
Plugin: utilsplugin2 (26986)

java.lang.NullPointerException
	at org.openstreetmap.josm.io.XmlWriter.encode(XmlWriter.java:26)
	at org.openstreetmap.josm.data.Preferences$SettingToXml.visit(Preferences.java:1530)
	at org.openstreetmap.josm.data.Preferences$ListListSetting.visit(Preferences.java:136)
	at org.openstreetmap.josm.data.Preferences.toXML(Preferences.java:1572)
	at org.openstreetmap.josm.data.Preferences.save(Preferences.java:470)
	at org.openstreetmap.josm.data.Preferences.put(Preferences.java:418)
	at org.openstreetmap.josm.data.Preferences.putInteger(Preferences.java:437)
	at org.openstreetmap.josm.gui.PleaseWaitDialog$1.componentResized(PleaseWaitDialog.java:67)
	at java.awt.AWTEventMulticaster.componentResized(AWTEventMulticaster.java:159)
	at java.awt.Component.processComponentEvent(Component.java:5962)
	at java.awt.Component.processEvent(Component.java:5916)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Window.processEvent(Window.java:1836)
	at java.awt.Component.dispatchEventImpl(Component.java:4497)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4323)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$2.run(EventQueue.java:622)
	at java.awt.EventQueue$2.run(EventQueue.java:620)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1492)
	at java.awt.Component.setVisible(Component.java:1444)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1492)
	at java.awt.Component.setVisible(Component.java:1444)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.setVisible(PreferenceDialog.java:99)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:38)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:34)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1664)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2851)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:285)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:234)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2928)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2920)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2814)
	at java.awt.Component.processEvent(Component.java:5913)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4497)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4323)
...<snip>.

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by bastiK

In [4614/josm]:

see #7088 - Preferences NullPointerException (more checks to find the cause of the error)

comment:2 Changed 10 years ago by bastiK

Please report again with version 4614.

comment:3 Changed 10 years ago by anonymous

Ticket #7091 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by bastiK

In [4616/josm]:

see #7088 - avoid NPE

comment:5 Changed 10 years ago by anonymous

In JOSM 4613 this error is still there.
In JOSM 4616 this error is not reproduceable.
Seems to be fixed.

comment:6 Changed 10 years ago by bastiK

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.