Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#7082 closed defect (fixed)

Strange result while merging nodes with CTRL

Reported by: mdk Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Load attached example and

  • Grab "Node 1" (keep LMB pressed)
  • Press CTRL (to merge node if you would release dragged node over an other node)
  • Move "Node 1" over "Node 2", but DON'T release "Node 1"

Now somthing strange happens: The grabed node is placed near "Node 2". A new Node is inserted in the middle of the way from "Node 1" to the end of the way. The new node is selected and will be dragged from now.

You can repeat this endless by dragging the new node over "Node 1" again :-)

Remember: keep CTRL pressed all the time!

Attachments (1)

Unexpected new Nodes.osm (961 bytes) - added by mdk 11 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by mdk

Attachment: Unexpected new Nodes.osm added

comment:1 Changed 11 years ago by joshdoe

Resolution: worksforme
Status: newclosed

I can't replicate this problem with r4842.

comment:2 Changed 10 years ago by akks

Resolution: worksforme
Status: closedreopened

This is Windows-specific bug, harder to reproduce in Linux, see #7888.

comment:3 Changed 10 years ago by akks

Resolution: fixed
Status: reopenedclosed

In 5418/josm:

fix #7082 (?) - CTRL-drag in selection mode problem, see #7888: SelectAction and MoveCommand rework

comment:4 Changed 10 years ago by akks

Please check if problem is gone on Windows/Linux.

comment:5 Changed 10 years ago by anonymous

Tested with 5419 on Ubuntu (OpenJDK): The Problem still exists.

The behavior on Windows I can test in some days. The fix for the repeated key_pressed events on Windows may change the behavior, so that the error occure only if CTRL is pressed near the virtual node (so Windows would now behave like Linux).

Here a little detail I saw while testing on Linux:

  1. To reproduce the error you have to take a node N1 an drag it near to a virtual node V1 (keep LMB pressed).
  2. If you press now CTRL (BUT DON'T MOVE THE MOUSE!), the cursor changes from the "drag hand" to "grab virtual node" (small cross with node symbol in the upper right corner).
  3. If you now move the mouse a little bit (still with pressed LMB and CTRL):
  • the original node N1, is droppen under the mouse.
  • The virtual node V1 is converted into a real node N2 and replaces the old selection (so the new node is now dragged).
  • N2 is placed with an offset wich is identical with the dragg vector of N1. (sill in drag mode)

If you press CTRL with no virtual node nearby, the cursor changes to a big outlined cross (CTRL merge nodes).

I hope this helps...

comment:6 Changed 10 years ago by akks

Resolution: fixed
Status: closedreopened

So the the simple trick only improved behaviour on Windows.

I'll try to fix this.

comment:7 Changed 10 years ago by akks

Resolution: fixed
Status: reopenedclosed

In 5435/josm:

hope to fix #7082: ctrl-dragging near virtual node problem

comment:8 Changed 10 years ago by akks

Check again, please :)

comment:9 Changed 10 years ago by mdk

Test with '5435 SVN' on Linux: the problem is fixed. Pressing CTRL now always change to "merge mode" (big outlined cross) and no longer to the "grab virtual node" mode.

I will try to test this on Windows tomorrow.

Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.