Modify

Opened 9 years ago

Closed 9 years ago

#7074 closed defect (fixed)

Crash after purging some data

Reported by: Polyglot Owned by: jttt
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-11-23 02:32:11
Last Changed Author: stoecker
Revision: 4605
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-11-22 08:48:52 +0100 (Tue, 22 Nov 2011)
Last Changed Rev: 4605

Identification: JOSM/1.5 (4605 en)
Memory Usage: 532 MB / 821 MB (76 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: AddrInterpolation (26731)
Plugin: Create_grid_of_ways (26731)
Plugin: Curves (17.master-d10ded7)
Plugin: DirectUpload (26849)
Plugin: FixAddresses (26986)
Plugin: ImproveWayAccuracy (26986)
Plugin: OpeningHoursEditor (26986)
Plugin: alignways (26986)
Plugin: buildings_tools (26731)
Plugin: contourmerge (1003)
Plugin: dataimport (26731)
Plugin: download_along (26731)
Plugin: editgpx (26731)
Plugin: graphview (26986)
Plugin: licensechange (26986)
Plugin: mapdust (26731)
Plugin: measurement (26731)
Plugin: openstreetbugs (26986)
Plugin: osmarender (26833)
Plugin: public_transport (26986)
Plugin: reltoolbox (26986)
Plugin: reverter (27091)
Plugin: routing (26986)
Plugin: scripting (26005)
Plugin: terracer (26731)
Plugin: turnlanes (26731)
Plugin: turnrestrictions (26986)
Plugin: undelete (26928)
Plugin: utilsplugin2 (26986)
Plugin: walkingpapers (26928)
Plugin: waydownloader (26986)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Relation id=5424 version=85 VT [way 4952681, way 5032579, way 5032580, way 5034394, way 5034397, way 5034543, way 5041954, way 5041957, way 5041960, way 5049053, way 5073848, way 5110440, way 5110442, way 5110443, way 5110444, way 5136349, way 5136350, way 5136417, way 5136419, way 5940062, way 5940063, way 5940064, way 5940078, way 109785793, way 7975835, way 108666408, way 8034622, way 8045062, way 8045063, way 8159469, way 8159474, way 8159475, way 8160280, way 8169361, way 8481207, way 14025227, way 19801090, way 22907884, way 22907910, way 22907911, way 22908080, way 22908212, way 22908247, way 22909092, way 22909100, way 22909183, way 22909187, way 22909188, way 22909198, way 22909201, way 22909234, way 22909243, way 22909278, way 115095189, way 22909308, way 22909314, way 22909315, way 22909316, way 22938416, way 22938899, way 125956097, way 22938965, way 22938993, way 22939420, way 22946320, way 22949011, way 22997274, way 22997385, way 22997662, way 22997665, way 22997667, way 22997668, way 22997683, way 22997714, way 22997758, way 22997759, way 22997927, way 22998063, way 109264611, way 22998151, way 22998160, way 22998164, way 22998183, way 109883619, way 22998187, way 22998207, way 22998225, way 22998229, way 22998237, way 22998261, way 22998265, way 127873230, way 23463980, way 23902136, way 23902161, way 23902267, way 23902342, way 23902351, way 23902372, way 27661342, way 27662745, way 27664313, way 27782998, way 36552650, way 22908954, way 93183573, way 123450675, way 22908944, way 22908968, way 22908971, way 36564534, way 36733398, way 23722212, way 23722211, way 22908549, way 8572266, way 8507169, way 22908566, way 36558228, way 22908577, way 8572189, way 22908988, way 22912107, way 22908993, way 22909000, way 22909019, way 22909030, way 36736964, way 22909082, way 22909084, way 30127193, way 36737839, way 36995815, way 8507186]}

at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:309)
at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:841)
at org.openstreetmap.josm.tools.template_engine.ContextSwitchTemplate$ParentSet.getPrimitives(ContextSwitchTemplate.java:70)
at org.openstreetmap.josm.tools.template_engine.ContextSwitchTemplate.appendText(ContextSwitchTemplate.java:249)
at org.openstreetmap.josm.tools.template_engine.CompoundTemplateEntry.appendText(CompoundTemplateEntry.java:25)
at org.openstreetmap.josm.gui.DefaultNameFormatter.formatRelationNameAndType(DefaultNameFormatter.java:340)
at org.openstreetmap.josm.gui.DefaultNameFormatter.format(DefaultNameFormatter.java:306)
at org.openstreetmap.josm.data.osm.Relation.getDisplayName(Relation.java:376)
at org.openstreetmap.josm.gui.OsmPrimitivRenderer.getComponentText(OsmPrimitivRenderer.java:96)
at org.openstreetmap.josm.gui.OsmPrimitivRenderer.renderer(OsmPrimitivRenderer.java:69)
at org.openstreetmap.josm.gui.OsmPrimitivRenderer.getListCellRendererComponent(OsmPrimitivRenderer.java:44)
at javax.swing.plaf.basic.BasicListUI.paintCell(Unknown Source)
at javax.swing.plaf.basic.BasicListUI.paintImpl(Unknown Source)
at javax.swing.plaf.basic.BasicListUI.paint(Unknown Source)
at javax.swing.plaf.ComponentUI.update(Unknown Source)
at javax.swing.JComponent.paintComponent(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JViewport.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at org.openstreetmap.josm.gui.MultiSplitPane.paintChildren(MultiSplitPane.java:205)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JSplitPane.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JLayeredPane.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paintToOffscreen(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
at java.awt.Container.paint(Unknown Source)
at java.awt.Window.paint(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by jttt

Owner: changed from team to jttt

Related to name templates

comment:2 Changed 9 years ago by skyper

Ticket #7108 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by jttt

Resolution: fixed
Status: newclosed

In [4725/josm]:

Fix #7074 Crash after purging some data

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.