Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6995 closed defect (duplicate)

Error while uploading

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM (active projection : Mercator)
  2. change projection to Lambert9-France/Zone2
  3. Download an area of Toulouse
  4. Open a JOSM file containing buildings of Toulouse
  5. Select one building (6 polygon),
  6. "merge selection" to "Calque de données 1"
  7. delete the imported file
  8. In "Calque de données 1", create a multipolygon relation corresponding to the new builing.
  9. "Envoyer les modifications du calque actif" (ctrl+maj+U)

Error hapens.

What is the expected result?

Normal upload of data to the serever

What happens instead?

A pop-up windows saying "an error has happened"

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-10-04 01:31:24
Last Changed Author: bastiK
Revision: 4487
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-10-03 22:52:38 +0200 (Mon, 03 Oct 2011)
Last Changed Rev: 4487

Identification: JOSM/1.5 (4487 fr)
Memory Usage: 238 MB / 247 MB (65 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: cadastre-fr (26835)
Plugin: licensechange (26606)
Plugin: openstreetbugs (26606)
Plugin: turnrestrictions (26666)

org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
	at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:473)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesAsDiffUpload(OsmServerWriter.java:119)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:195)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:233)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:79)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:125)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by skyper

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by skyper

Closed as duplicate of #6999.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.