Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6991 closed defect (fixed)

Columbus Plugin crashes at Startup

Reported by: Teddych Owned by: OliverW
Priority: major Milestone:
Component: Plugin columbuscsv Version: tested
Keywords: Cc:

Description

The columbus plugin crashes at startup with the following Exception:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-10-04 01:31:24
Last Changed Author: bastiK
Revision: 4487
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-10-03 22:52:38 +0200 (Mon, 03 Oct 2011)
Last Changed Rev: 4487
GET http://api.openstreetmap.org/api/capabilities... OK
Communications with http://api.openstreetmap.org/api established using protocol version 0.6.
loading plugin 'ColumbusCSV' (version 26605)
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin ColumbusCSV

at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:280)
at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:475)
at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:533)
at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:572)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:245)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:271)
... 4 more

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.tools.I18n.tr(Ljava/lang/String;)Ljava/lang/String;

at org.openstreetmap.josm.plugins.columbusCSV.ColumbusCSVImporter.<init>(ColumbusCSVImporter.java:42)
at org.openstreetmap.josm.plugins.columbusCSV.ColumbusCSVPlugin.<init>(ColumbusCSVPlugin.java:36)
... 9 more

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by anonymous

Fixed in [o26946].

Last edited 10 years ago by stoecker (previous) (diff)

comment:2 Changed 10 years ago by OliverW

Resolution: fixed
Status: newclosed

comment:3 Changed 10 years ago by anonymous

Ticket #6986 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.