Modify

Opened 9 years ago

Closed 9 years ago

#6900 closed defect (fixed)

unglue confirmation within downloaded area

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: unglue confirmation Cc: simon04

Description (last modified by skyper)

I get "unglue confirmation" window within downloaded area.

I have downloaded several small areas in one data layer and the way has parts out of downloaded area but the node is not far but definitly inside the downloaded area. Have a look:

screenshot

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-09-26 01:32:24
Last Changed Author: simon04
Revision: 4465
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-09-25 19:48:57 +0200 (Sun, 25 Sep 2011)
Last Changed Rev: 4465

Identification: JOSM/1.5 (4465 de)
Memory Usage: 248 MB / 248 MB (40 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Dataset consistency test:
[NO DATASET] {Relation id=1079463 version=10 VT [Linie 68747985, Linie 58522873, Linie 70702300, Linie 51731426, Linie 45899436, Linie 45899434, Linie 45899435, Linie 45899433, Linie 45899341, Linie 114822582, Linie 53799580, Linie 53799585, Linie 53799575, Linie 53799699, Linie 53799683, Linie 53799684, Linie 53799739, Linie 127096653, Linie 127096645, Linie 53799738, Linie 53799725, Linie 53799717, Linie 53799718, Linie 53799587, Linie 53799661, Linie 53799662, Linie 41455472, Linie 41455470, Linie 41455471, Linie 41455469, Linie 23226962, Linie 23226963, Linie 53272078, Linie 53272061, Linie 53272101, Linie 53272085, Linie 53272110, Linie 53272057, Linie 54828129, Linie 54828142, Linie 53272115, Linie 53272040, Linie 53272052, Linie 55578174, Linie 55573553, Linie 42220767, Linie 42861128, Linie 55491617, Linie 55491593, Punkt 695284331, Linie 114018145, Punkt 695284356, Linie 114034620, Punkt 695284353, Linie 114034618, Punkt 695284308, Linie 55490326, Punkt 695284313, Linie 55490312, Punkt 695284369, Linie 55490309, Punkt 585142351, Punkt 660196365, Linie 42024245, Punkt 585142394, Punkt 653314207, Linie 50069797, Punkt 585142188, Punkt 653314193, Linie 50069782, Punkt 679144228, Punkt 843274492, Linie 38614658, Punkt 679144472, Linie 53799696, Punkt 679144535, Punkt 679144536, Punkt 679144426, Punkt 679144424, Punkt 248609028, Linie 45328829, Linie 87988134, Punkt 674055859, Linie 23243975, Punkt 674055904, Linie 53272112, Punkt 674055933, Linie 53272116, Punkt 674055660, Linie 53272054, Punkt 698508877, Punkt 1292291233, Punkt 698508904, Punkt 1292291256, Punkt 698509028, Punkt 1292291250, Punkt 297604124, Linie 55491619]} is referenced by {Relation id=69191 version=80 VT [Relation 1079463, Relation 1079464]} but not found in dataset
[NO DATASET] {Relation id=1079464 version=7 VT [Linie 68747989, Linie 55491590, Linie 42220781, Linie 42220780, Linie 30438372, Linie 55578141, Linie 42220768, Linie 23042836, Linie 53272114, Linie 53272058, Linie 54828130, Linie 53272109, Linie 55578117, Linie 53272086, Linie 23042834, Linie 53272062, Linie 53799638, Linie 23042835, Linie 23226988, Linie 23226989, Linie 41455467, Linie 41455479, Linie 43844559, Linie 41821804, Linie 41455482, Linie 41455478, Linie 42021068, Linie 53799727, Linie 30324962, Linie 53799680, Linie 30326372, Linie 30613810, Linie 30326442, Linie 9943741, Linie 9943742, Linie 4885894, Linie 23227034, Linie 30325001, Linie 7970767, Linie 4522504, Linie 43624130, Linie 23249933, Linie 51731430, Linie 58522874, Punkt 297604124, Linie 55491619, Punkt 29670387, Punkt 1292291254, Punkt 804412074, Punkt 1292291251, Punkt 28804605, Punkt 1292291244, Punkt 339131741, Linie 53272055, Punkt 298524222, Linie 53272117, Punkt 250957536, Linie 53272111, Punkt 248609026, Linie 53272104, Punkt 248609020, Punkt 674055756, Punkt 31457734, Punkt 679144581, Punkt 298518321, Punkt 679144537, Punkt 251287559, Linie 53799697, Punkt 26388996, Punkt 843274483, Linie 38614634, Punkt 653314196, Punkt 31683483, Linie 50069789, Punkt 249505551, Punkt 653314206, Linie 50069796, Punkt 64932993, Punkt 660196366, Linie 37550093, Punkt 27797392, Linie 55490316, Punkt 27797523, Linie 55490322, Punkt 59764255, Linie 55490323, Punkt 60225277, Linie 114034617, Punkt 60227142, Linie 114034619, Punkt 333803726, Linie 114018144]} is referenced by {Relation id=69191 version=80 VT [Relation 1079463, Relation 1079464]} but not found in dataset


Attachments (2)

screenshot_6900.png (49.9 KB) - added by skyper 9 years ago.
screenshot
6900_example.osm (58.3 KB) - added by skyper 9 years ago.
example osm

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by skyper

Attachment: screenshot_6900.png added

screenshot

comment:1 Changed 9 years ago by skyper

Description: modified (diff)

comment:2 Changed 9 years ago by bastiK

Hi skyper, thanks for the report.

Please attach the osm file where this happens and tell the node id.

Maybe unrelated, but the Dataset consistency test indicates a serious problem. If you ever find a way to reproduce such Dataset inconsistencies, please let us know.

comment:3 in reply to:  2 Changed 9 years ago by skyper

Replying to bastiK:

Hi skyper, thanks for the report.

You are welcome.

Please attach the osm file where this happens and tell the node id.

attached. node id:427697606.
Sorry, did not have the original one.

Maybe unrelated, but the Dataset consistency test indicates a serious problem. If you ever find a way to reproduce such Dataset

inconsistencies, please let us know.

It is not that hard to reproduce (also in other areas) and without data inconsistency.

I watch out for the inconsistencies but all I can tell you so far:

  • I often download several small parts in on layer or in several layers and merge them later. Resulting in osm files with several small areas and a lot of incomplete data.

There are still major problems when merging several edited layers - So I stop working offline, but I still get these inconsistencies from time to time.

Last edited 9 years ago by skyper (previous) (diff)

Changed 9 years ago by skyper

Attachment: 6900_example.osm added

example osm

comment:4 Changed 9 years ago by skyper

Cc: simon04 added
Description: modified (diff)

This is definitly a regression of r3951 and gets annoying.

comment:5 Changed 9 years ago by skyper

Ticket #7085 has been marked as a duplicate of this ticket.

comment:6 Changed 9 years ago by anonymous

Ticket #7081 has been marked as a duplicate of this ticket.

comment:7 Changed 9 years ago by anonymous

The alert happens anywhere, but only if you the way that is partially outside the downloaded area is selected along with the node. If you only select a node, it works as it should. (I don't get data inconsistency errors)

comment:8 Changed 9 years ago by simon04

Resolution: fixed
Status: newclosed

In [4650/josm]:

fix #6900 - unglue confirmation within downloaded area

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.