Modify

Opened 7 years ago

Closed 4 years ago

Last modified 3 years ago

#6896 closed enhancement (fixed)

New logo

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 14.11
Component: Core Version: latest
Keywords: logo contest svg Cc: Klumbumbus

Description (last modified by Don-vip)

I have created a new logo based on the recent OSM logo change.
What do you think about it ?



EDIT: Final phase of the logo contest which took place from July to November 2014:

LogoContest#FinalphaseOctober-November2014


EDIT2: Diamond00744 is the winner!

Attachments (8)

logo_16x16.png (3.6 KB) - added by Don-vip 7 years ago.
logo_32x32.png (5.6 KB) - added by Don-vip 7 years ago.
logo_48x48.png (8.4 KB) - added by Don-vip 7 years ago.
logo_64x64.png (11.9 KB) - added by Don-vip 7 years ago.
logo_128x128.png (30.8 KB) - added by Don-vip 7 years ago.
logo_200x200.png (51.9 KB) - added by Don-vip 7 years ago.
logo_rasher.svg (179.5 KB) - added by rasher 7 years ago.
setup.png (123.6 KB) - added by Don-vip 4 years ago.

Download all attachments as: .zip

Change History (67)

Changed 7 years ago by Don-vip

Attachment: logo_16x16.png added

Changed 7 years ago by Don-vip

Attachment: logo_32x32.png added

Changed 7 years ago by Don-vip

Attachment: logo_48x48.png added

Changed 7 years ago by Don-vip

Attachment: logo_64x64.png added

Changed 7 years ago by Don-vip

Attachment: logo_128x128.png added

Changed 7 years ago by Don-vip

Attachment: logo_200x200.png added

comment:1 Changed 7 years ago by skyper

Nice, is there also a scalable .svg available ?

comment:2 Changed 7 years ago by Don-vip

No, I cannot open the OSM SVG file with Illustrator :( And sadly, the Java cup used is only available in PNG :(

comment:3 in reply to:  2 Changed 7 years ago by skyper

Replying to Don-vip:

... And sadly, the Java cup used is only available in PNG :(

Window manager can use other formats.

comment:4 in reply to:  2 Changed 7 years ago by simon04

Replying to Don-vip:

And sadly, the Java cup used is only available in PNG :(

Perhaps we can take the cup from Oxygen Icons:

comment:5 Changed 7 years ago by bastiK

According to the wiki, the new OSM logo is available under the terms of cc-by-sa. Depending on the interpretation of the GPL, it may or may not be possible to distribute this image as part of GPL-licensed software. You could try to contact the original author in order to get a special license for JOSM.

By the way, the OSM logo is a registered trademark and JOSM is not formally associated with OpenStreetMap. I guess it is tolerated by the OSMF (no one has complained so far), but in principle it would be better to have some kind of approval.

Personally, I'd prefer if someone came up with a good, completely new logo design.

comment:6 in reply to:  5 Changed 7 years ago by stoecker

Replying to bastiK:

Personally, I'd prefer if someone came up with a good, completely new logo design.

Me too.

comment:7 Changed 7 years ago by simon04

I asked the folks from Development Seed whether they would design a new logo. Happily, they agreed. I'm looking forward to seeing a draft :-)

comment:8 Changed 7 years ago by simon04

Summary: [Patch] New logoNew logo

comment:9 Changed 7 years ago by Don-vip

great ! :)

comment:10 in reply to:  7 Changed 7 years ago by Don-vip

Description: modified (diff)

Replying to simon04:

Happily, they agreed. I'm looking forward to seeing a draft :-)

Any news on this ? :)

comment:11 Changed 7 years ago by simon04

Ticket #6516 has been marked as a duplicate of this ticket.

comment:12 Changed 7 years ago by Don-vip

3 months without logo nor news :(

comment:13 Changed 7 years ago by simon04

Apparently, they are quite busy, but (as far as they told me) they are working on it.

comment:14 Changed 7 years ago by Don-vip

OK :) Could they also have a look to this branding image ? http://trac.openstreetmap.org/browser/applications/editors/josm/nsis/josm-nsis-brand.bmp It's a BMP for the Windows installer, far from being sexy :)

comment:15 Changed 7 years ago by bastiK

Any updates, new ideas?

comment:16 Changed 7 years ago by rasher

I had a go at this, without knowing this ticket existed, using a coffee cup from openclipart.org (CC0).

Changed 7 years ago by rasher

Attachment: logo_rasher.svg added

comment:17 in reply to:  16 Changed 7 years ago by bastiK

Replying to rasher:

I had a go at this, without knowing this ticket existed, using a coffee cup from openclipart.org (CC0).

Thanks rasher, but we are currently looking for a new logo, that doesn't have a coffee cup or the OSM icon in it.

comment:18 Changed 6 years ago by Don-vip

Still no update on this ? Maybe we could run a contest among OSM community ?

comment:19 Changed 5 years ago by anonymous

Priority: minormajor

Really, what happened? I'm still laughing when I see the oldschool OSM icon in my taskbar -.-

comment:20 Changed 5 years ago by bastiK

Priority: majornormal

Nothing happened.

comment:21 Changed 5 years ago by Don-vip

I'd like to see some progress on this. What about of setting up a logo contest, with massive visibility? Something visible on our main page, on OSM wiki, mailing lists, OSM blogs, social networks, etc.

I don't think we can afford any prize, but still :)

comment:22 Changed 5 years ago by bastiK

I support this idea!

For reference, there have been logo competitions by the OMSF and by HOT.

comment:23 Changed 5 years ago by stoecker

We can offer a "free license of josm" as price :-)

comment:24 Changed 5 years ago by Don-vip

I have setup this wiki page: JOSM/Graphic_Contest by copying the HOT competition page.

Can everyone of you please:

  • read it, fix language mistakes
  • tell me what's not clear

To core developers:

  • does the time window looks good? (all summer + month of september. It should allow us to have student participations I hope)
  • who wants to be part of the jury? It may involve receiving a lot of e-mails
  • I have copied the "feedback" part from HOT page, do you think it's a good idea or should we remove this part?
  • Dirk, can you create the "contest" e-mail address? Or tell me if you've a better idea than a one-time e-mail address redirecting mails to jury's members inboxes

comment:25 Changed 5 years ago by bastiK

Great!

  • In order to avoid trouble and allow use in different scenarios, we should really require, that the logo is released under CC0 (public domain). As it stands, we couldn't even put the logo on our own website... Also I'm not sure you can waive your rights in favor of the JOSM project because we aren't a company, foundation or anything like that.
  • For me, it would suffice to get a single mail with all the entries after the end of the deadline.
  • The contestants should get a confirmation mail not more than 48 hours after submission and this should be stated in the rules.
  • Feedback isn't really necessary in my opinion (unless asked for).
  • I don't really care for the banners in the windows installer and on the social media sites, but what I would love to see at some point is a recognizable custom design for the JOSM website. Without touching the functionality of trac, you can probably do a lot by changing the color scheme, replacing graphical elements and some CSS. (This shouldn't be part of the current contest.)

comment:26 in reply to:  25 ; Changed 5 years ago by Don-vip

Replying to bastiK:

  • In order to avoid trouble and allow use in different scenarios, we should really require, that the logo is released under CC0 (public domain). As it stands, we couldn't even put the logo on our own website... Also I'm not sure you can waive your rights in favor of the JOSM project because we aren't a company, foundation or anything like that.

I have stated CC0 as a requirement and simplified all the copyright talk.

  • For me, it would suffice to get a single mail with all the entries after the end of the deadline.

I'm not sure to understand? A deadline is a deadline, why should we allow contestants to send a mail after it?

  • The contestants should get a confirmation mail not more than 48 hours after submission and this should be stated in the rules.

Added.

  • Feedback isn't really necessary in my opinion (unless asked for).

I agree. Removed.

  • I don't really care for the banners in the windows installer and on the social media sites, but what I would love to see at some point is a recognizable custom design for the JOSM website. Without touching the functionality of trac, you can probably do a lot by changing the color scheme, replacing graphical elements and some CSS. (This shouldn't be part of the current contest.)

+1, but let's keep that for later :)

comment:27 in reply to:  26 Changed 5 years ago by bastiK

Replying to Don-vip:

  • For me, it would suffice to get a single mail with all the entries after the end of the deadline.

I'm not sure to understand? A deadline is a deadline, why should we allow contestants to send a mail after it?

Someone collects the entries and presents them to the rest of the jury for evaluation. I don't mind really, just an idea.

comment:28 in reply to:  26 ; Changed 5 years ago by skyper

Replying to Don-vip:

Replying to bastiK:

  • In order to avoid trouble and allow use in different scenarios, we should really require, that the logo is released under CC0 (public domain). As it stands, we couldn't even put the logo on our own website... Also I'm not sure you can waive your rights in favor of the JOSM project because we aren't a company, foundation or anything like that.

I have stated CC0 as a requirement and simplified all the copyright talk.

How about GPL ? A .svg-file is code, isn't it ?

comment:29 in reply to:  28 Changed 5 years ago by bastiK

Replying to skyper:

I have stated CC0 as a requirement and simplified all the copyright talk.

How about GPL ? A .svg-file is code, isn't it ?

CC0 is as close as you can get to public domain under the different jurisdictions. It can be relicensed to most other open source licenses, including GPL.

comment:30 in reply to:  24 ; Changed 5 years ago by stoecker

Replying to Don-vip:

  • Dirk, can you create the "contest" e-mail address? Or tell me if you've a better idea than a one-time e-mail address redirecting mails to jury's members inboxes

Done. Currently added you, Paul and me.

would love to see at some point is a recognizable custom design for the JOSM website

Add it as "P.S. Other things we'd need in future". So if someone does not know how to make logos but is perfect in website design, he can nevertheless help when seeing the page.

Notes:

  • I'd add a note that the old design is also part of the competition and may win. :-)
  • I'd release submissions when we get them, so not making the process invisible. We don't offer high prices, so let's work with the community. Maybe someones sees a good idea from somebody else and can improve it.

comment:31 in reply to:  30 Changed 5 years ago by bastiK

Replying to stoecker:

Replying to Don-vip:

  • Dirk, can you create the "contest" e-mail address? Or tell me if you've a better idea than a one-time e-mail address redirecting mails to jury's members inboxes

Done. Currently added you, Paul and me.

Thanks!

Notes:

  • I'd add a note that the old design is also part of the competition and may win. :-)

Added this.

  • I'd release submissions when we get them, so not making the process invisible. We don't offer high prices, so let's work with the community.

Maybe...

Maybe someones sees a good idea from somebody else and can improve it.

Not sure if artists think that way, this would be plagiarizing and stealing of ideas in the real world (especially when it's a competition). :)

comment:32 Changed 5 years ago by Don-vip

We can keep the entries private for this contest, and if nothing gets out of it, we could setup another round with this "public" approach I think.

comment:33 Changed 5 years ago by Don-vip

Keywords: logo contest svg added
Milestone: 14.10

The contest is going well we already have received several interesting submissions :)

comment:34 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:35 Changed 4 years ago by stoecker

Results see LogoContest. Send us your opinions to contest at josm.openstreetmap.de.

comment:36 Changed 4 years ago by Don-vip

Milestone: 14.1014.11

Final phase takes a bit longer than expected, we should however have a new logo for the next release :)

comment:37 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:38 Changed 4 years ago by stoecker

In 7765/josm:

see #6896 - checkin new logo data

comment:39 in reply to:  38 Changed 4 years ago by SammysHP

Replying to stoecker:

Can you please add also the PNG version of the logo in josm/trunk/images/logo.png?

comment:40 Changed 4 years ago by Don-vip

In 7768/josm:

see #6896 - update logo images - use new logo at fixed resolution in spash screen

comment:41 Changed 4 years ago by rickmastfan67

Don't forget that the 'old' logo is still used in the 'View' menu for the 'Advanced info' and 'History' entries. (r7768) It is also used in the 'Help' menu for the 'About' entry. Just thought I would mention this so they aren't forgotten, and get updated before the next 'tested' as well.

Last edited 4 years ago by rickmastfan67 (previous) (diff)

comment:42 in reply to:  41 Changed 4 years ago by Klumbumbus

Replying to rickmastfan67:

the 'Advanced info' and 'History' entries.

I think they should get other icons. Maybe source:trunk/images/info.png for info and source:trunk/images/dialogs/history.png for history

comment:43 Changed 4 years ago by bastiK

In 7770/josm:

see #6896 - replace favicon images with new logo

comment:44 Changed 4 years ago by bastiK

Resolution: fixed
Status: newclosed

In [7771/josm]:
fixes #1608 - remove remaining old logos

comment:46 Changed 4 years ago by Klumbumbus

...and the favicon of this website

comment:47 Changed 4 years ago by Don-vip

Windows stuff updated in [o30835].

comment:48 Changed 4 years ago by Don-vip

In 7772/josm:

fix #6896 - update OSX icon with new logo

comment:49 Changed 4 years ago by Don-vip

In 7773/josm:

see #6896 - generate new and optimized favicons with http://realfavicongenerator.net

comment:50 in reply to:  46 Changed 4 years ago by Don-vip

Replying to Klumbumbus:

...and the favicon of this website

Done.

comment:51 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:52 Changed 4 years ago by Klumbumbus

The history window and the loading history progress window have the JOSM logo as icon. They should use source:trunk/images/dialogs/history.png.

comment:53 in reply to:  52 ; Changed 4 years ago by Don-vip

Replying to Klumbumbus:

The history window and the loading history progress window have the JOSM logo as icon. They should use source:trunk/images/dialogs/history.png.

it's not release-blocking, please create a new ticket for the next milestone, I'm releasing r7777 as new tested.

comment:54 in reply to:  53 Changed 4 years ago by Klumbumbus

Replying to Don-vip:

please create a new ticket for the next milestone

See #10823

Changed 4 years ago by Don-vip

Attachment: setup.png added

comment:55 Changed 4 years ago by Don-vip

The Windows installer looks awesome now !



Last edited 4 years ago by Don-vip (previous) (diff)

comment:56 Changed 4 years ago by Don-vip

Logo changed on:

I think that's all?

comment:57 Changed 4 years ago by bastiK

Icons for the Ubuntu package are not updated yet. I'm on it.

comment:58 Changed 4 years ago by bastiK

In 7778/josm:

see #6896 - update logo for ubuntu package

comment:59 Changed 4 years ago by Don-vip

In 7799/josm:

see #6896 - add logo attribution in CONTRIBUTION file

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.