Modify

Opened 8 years ago

Closed 6 years ago

#6872 closed defect (fixed)

measurement plugin inconsistencies of selections with nodes and ways

Reported by: dieterdreist Owned by: team
Priority: normal Milestone:
Component: Plugin measurement Version: latest
Keywords: measurement selection node way Cc:

Description (last modified by skyper)

There is some inconsistency in the measurement plugin: if you draw a square with 100m length of its side, and select the way the selection length is displayed as 400 meters. When you now select the nodes of the sides as well, the displayed selection length is 700 meters.

Another issue seems to be the displayed area: the selection area of the above square 100x100 is 9582.26 m². When moving the "square" to the south until the area is displayed as 10000.00 m² the displayed selection lenght of the way is 408.42 m

Btw: The displayed "path length" is always 0.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by dieterdreist

Description: modified (diff)

comment:2 in reply to:  description Changed 7 years ago by skyper

Description: modified (diff)

Replying to dieterdreist:

Can reproduce!

There is some inconsistency in the measurement plugin: if you draw a square with 100m length of its side, and select the way the selection length is displayed as 400 meters. When you now select the nodes of the sides as well, the displayed selection length is 700 meters.

Seem to adding up the way and the distance between the nodes.

Another issue seems to be the displayed area: the selection area of the above square 100x100 is 9582.26 m². When moving the "square" to the south until the area is displayed as 10000.00 m² the displayed selection lenght of the way is 408.42 m

We are in spheres and not in 2D but I am not sure about the results, think the areas should be larger.

Btw: The displayed "path length" is always 0.

yes.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-31 02:32:35
Last Changed Author: stoecker
Revision: 4879
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-30 20:33:08 +0100 (Mon, 30 Jan 2012)
Last Changed Rev: 4879

Identification: JOSM/1.5 (4879 en)
Memory Usage: 69 MB / 508 MB (19 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: measurement (26706)

comment:3 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o29578] and [o29579].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.