Modify

Opened 7 years ago

Closed 6 years ago

#6704 closed enhancement (fixed)

Please provide shortcut configuration (for presets)

Reported by: tille@… Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by simon04)

Hi

some frequently used menu items in JOSM are "hidden" in a third level menu which always requires a lot of mouse movements for instance to navigate to a certain template. It would be really cool if it would be possible to define keyboard shortcuts as it is possible with Gimp: Just highlighting a menu item and press a shortcut of your choice.

Kind regards

Andreas

--
http://fam-tille.de

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by stoecker

Resolution: worksforme
Status: newclosed

Simply go to settings and define the shortcuts in the appropriate section.

comment:2 Changed 7 years ago by tille@…

Resolution: worksforme
Status: closedreopened

Hi again,

it seems I did not described the problem properly enough. Yes, there are defined shortcuts in JOSM but as far as I can see in the "Shortcut Preferences" dialogue these are available for a *defined set* of commands. HOwever, I would like to have something like:

Presets

-> Facilities

-> Tourism

-> Map

Say on <Ctrl+Alt>M or something like this.

Kind regards

Andreas.

comment:3 Changed 7 years ago by skyper

Just a way to lower mouse movements:

Do you know about toolbar and the possibility to individually customize it ?
Tourism is even located in it with default settings.

Cheers

comment:4 Changed 7 years ago by stoecker

Ticket #7076 has been marked as a duplicate of this ticket.

comment:5 Changed 7 years ago by simon04

Description: modified (diff)
Summary: Please provide shortcut configurationPlease provide shortcut configuration (for presets)

Do you know [F3], which opens a searchable list of all presets?

comment:6 Changed 6 years ago by akks

Resolution: fixed
Status: reopenedclosed

Currently you can put the needed button on toolbar and then create shortcut for it (use toolbar context menu to simpilfy the process).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.