Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6650 closed defect (fixed)

Crash

Reported by: anonymous Owned by: OliverW
Priority: normal Milestone:
Component: Plugin elevationprofile Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-07-11 01:31:35
Last Changed Author: stoecker
Revision: 4223
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-10 22:46:41 +0200 (Sun, 10 Jul 2011)
Last Changed Rev: 4223

Identification: JOSM/1.5 (4223 de)
Memory Usage: 102 MB / 503 MB (46 MB allocated, but free)
Java version: 1.6.0_26, Apple Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X
Dataset consistency test: No problems found

Plugin: AddrInterpolation (26284)
Plugin: CommandLine (26174)
Plugin: Create_grid_of_ways (26174)
Plugin: Curves (16.master-4f7c5a0)
Plugin: DirectDownload (26174)
Plugin: DirectUpload (26284)
Plugin: ElevationProfile (26174)
Plugin: FastDraw (26311)
Plugin: FixAddresses (26299)
Plugin: ImageWayPoint (26174)
Plugin: ImportImagePlugin (26174)
Plugin: ImproveWayAccuracy (26224)
Plugin: InfoMode (26399)
Plugin: OpeningHoursEditor (26284)
Plugin: PicLayer (26174)
Plugin: RoadSigns (26401)
Plugin: SeaMapEditor (26307)
Plugin: SimplifyArea (26224)
Plugin: alignways (26174)
Plugin: buildings_tools (26254)
Plugin: contourmerge (1001)
Plugin: dataimport (26174)
Plugin: download_along (26174)
Plugin: editgpx (26284)
Plugin: ext_tools (26284)
Plugin: gpxfilter (26174)
Plugin: imageryadjust (26174)
Plugin: importvec (26174)
Plugin: irsrectify (26174)
Plugin: junctionchecking (26284)
Plugin: lakewalker (26174)
Plugin: licensechange (26377)
Plugin: livegps (26218)
Plugin: mapdust (26174)
Plugin: measurement (26174)
Plugin: michigan_left (26174)
Plugin: multipoly-convert (26254)
Plugin: namemanager (26284)
Plugin: openstreetbugs (26299)
Plugin: openvisible (26174)
Plugin: osmarender (26174)
Plugin: pdfimport (26224)
Plugin: photo_geotagging (26174)
Plugin: public_transport (26284)
Plugin: reltoolbox (26299)
Plugin: restart (26254)
Plugin: reverter (26254)
Plugin: routes (26174)
Plugin: routing (26284)
Plugin: scripting (26002)
Plugin: surveyor (26174)
Plugin: tageditor (26299)
Plugin: tagging-preset-tester (26174)
Plugin: terracer (26174)
Plugin: turnlanes (26316)
Plugin: turnrestrictions (26299)
Plugin: undelete (26254)
Plugin: utilsplugin2 (26395)
Plugin: waydownloader (26174)
Plugin: waypoint_search (26174)
Plugin: wayselector (26174)

java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.elevation.gui.ElevationProfileDialog.layerRemoved(ElevationProfileDialog.java:423)
	at org.openstreetmap.josm.gui.MapView.fireLayerRemoved(MapView.java:152)
	at org.openstreetmap.josm.gui.MapView.removeLayer(MapView.java:363)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:559)
	at josmrestartplugin.RestartJosmAction.actionPerformed(RestartJosmAction.java:27)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:809)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:850)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6373)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6138)
	at java.awt.Container.processEvent(Container.java:2085)
	at java.awt.Component.dispatchEventImpl(Component.java:4735)
	at java.awt.Container.dispatchEventImpl(Container.java:2143)
	at java.awt.Component.dispatchEvent(Component.java:4565)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4621)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
	at java.awt.Container.dispatchEventImpl(Container.java:2129)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4565)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:679)
	at java.awt.EventQueue.access$000(EventQueue.java:85)
	at java.awt.EventQueue$1.run(EventQueue.java:638)
	at java.awt.EventQueue$1.run(EventQueue.java:636)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
	at java.awt.EventQueue$2.run(EventQueue.java:652)
	at java.awt.EventQueue$2.run(EventQueue.java:650)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:649)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by stoecker

Component: CorePlugin elevationprofile
Owner: changed from team to OliverW

comment:2 Changed 10 years ago by anonymous

Fixed in 26174. Unfortunately I was not able to login - even with a new PW.

comment:3 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

comment:4 Changed 10 years ago by stoecker

In case you can't get your login working, contact me by mail to fix the issue.

comment:5 Changed 10 years ago by anonymous

Ticket #6465 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.