Modify

Opened 9 years ago

Closed 7 years ago

#6630 closed defect (fixed)

NPE when merging data

Reported by: Don-vip Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by Don-vip)

Got this error while trying to upload a deleted way still used by an existing relation (not loaded in JOSM).

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-07-21 01:31:28
Last Changed Author: bastiK
Revision: 4261
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-20 21:01:06 +0200 (Wed, 20 Jul 2011)
Last Changed Rev: 4261

Identification: JOSM/1.5 (4261 fr)
Memory Usage: 1841 MB / 3729 MB (441 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Dataset consistency test:
[NO DATASET] {Relation id=417424 version=27 VT [chemin 32521843, chemin 101780495, chemin 51260079, chemin 51260081, chemin 32521484, chemin 30412403, chemin 103010195, chemin 50544724, chemin 22635252, chemin 8029559, chemin 53819724, chemin 27800220, chemin 27800216, chemin 48064923, chemin 27800128, chemin 27800118, chemin 4612504, chemin 28757093, chemin 62212146, chemin 48733277, chemin 99799959, chemin 62212155, chemin 62211498, chemin 50895233, chemin 104796443, chemin 103010188, chemin 62211499, chemin 5137104, chemin 62081489, chemin 62081515, chemin 62081452, chemin 50887018, chemin 30635627, chemin 99274480, chemin 99959831, chemin 23044717, chemin 22695283, chemin 2305547, chemin 30238112, chemin 23044698, chemin 99272680, chemin 4612302, chemin 97539206, chemin 38184731, chemin 99272684, chemin 28129644, chemin 28108102, chemin 28065151, chemin 28065152, chemin 2305718, chemin 28344747, chemin 80138220, chemin 4695565, chemin 4612670, chemin 80138218, chemin 80138219, chemin 4695534, chemin 77684340, nœud 1174950228, nœud 1175048589, nœud 1155529422, nœud 1155529466, nœud 1155529439, nœud 1155529494, nœud 1155529339, nœud 1150978949, nœud 1155529489, nœud 1155529443, nœud 471004536, nœud 1175048620, nœud 1045297714, nœud 1148259767, nœud 1148259772, nœud 1155529463, nœud 1155529476, nœud 1175048549, nœud 1175048594, nœud 1175048613, nœud 1175048585]} is referenced by {Relation id=1557135 version=2 VT [relation 1448451, relation 1448450, relation 417424, relation 1448449]} but not found in dataset
[NO DATASET] {Relation id=1448449 version=6 VT [chemin 32521843, chemin 101780495, chemin 51260079, chemin 51260081, chemin 32521484, chemin 30412403, chemin 103010195, chemin 50544724, chemin 22635252, chemin 8029559, chemin 53819724, chemin 27800220, chemin 27800216, chemin 48064923, chemin 27800128, chemin 27800118, chemin 4612504, chemin 28757093, chemin 62212146, chemin 48733277, chemin 99799959, chemin 62212155, chemin 62211498, chemin 50895233, chemin 104796443, chemin 103010188, chemin 62211499, chemin 5137104, chemin 62081489, chemin 62081515, chemin 62081452, chemin 50887018, chemin 30635627, chemin 99274480, chemin 99959831, chemin 23044717, chemin 22695283, chemin 2305547, chemin 30238112, chemin 23044698, chemin 99272680, chemin 4612302, chemin 97539206, chemin 38184731, chemin 99272684, chemin 28129644, chemin 28108102, chemin 28065151, chemin 28065152, chemin 2305718, chemin 28344747, chemin 28065204, chemin 80138162, chemin 22949571, chemin 22949574, chemin 79943329, chemin 80138169, chemin 28065150, nœud 1174950228, nœud 1175048589, nœud 1155529422, nœud 1155529466, nœud 1155529439, nœud 1155529494, nœud 1155529339, nœud 1150978949, nœud 1155529489, nœud 1155529443, nœud 1175048620, nœud 471004536, nœud 1045297714, nœud 1148259767, nœud 1148259772, nœud 1155529463, nœud 1155529476, nœud 1155529382, nœud 1155529324, nœud 1155529481, nœud 1155529357, nœud 1155529358]} is referenced by {Relation id=1557135 version=2 VT [relation 1448451, relation 1448450, relation 417424, relation 1448449]} but not found in dataset
[NO DATASET] {Relation id=414828 version=20 VT [chemin 99270774, chemin 99272681, chemin 22695943, chemin 23044717, chemin 99959830, chemin 99274481, chemin 99274480, chemin 99959832, chemin 49427820, chemin 108742065, chemin 4612449, chemin 99270759, chemin 99270748, chemin 109448380, chemin 109448381, chemin 108979303, chemin 122194079, chemin 5210175, chemin 116503252, chemin 116503255, chemin 64845304, chemin 22892315, chemin 64845300, chemin 22892312, chemin 22892313, chemin 99348778, chemin 22892318, chemin 99348769, chemin 61736376, chemin 2305389, chemin 4695551, chemin 2305016, chemin 4695590, chemin 4612456, chemin 22392523, chemin 32241590, chemin 50887017, chemin 50891354, chemin 99270773, chemin 99340611, chemin 99340612, chemin 2305291, chemin 2305292, chemin 99270767, nœud 1148214229, nœud 1148214335, nœud 1148214320, nœud 1148214310, nœud 1148214305, nœud 1148214269, nœud 998409744, nœud 894579376, nœud 1148214317, nœud 1148214286, nœud 1148214252, nœud 1148214326, nœud 1148214235, nœud 1148214278, nœud 1148214213]} is referenced by {Relation id=1557099 version=2 VT [relation 1421657, relation 414828]} but not found in dataset
[NO DATASET] {Relation id=1421675 version=9 VT [chemin 99272681, chemin 22695943, chemin 22695283, chemin 2305547, chemin 30238112, chemin 23044698, chemin 99272680, chemin 4612302, chemin 97539206, chemin 38184731, chemin 24848515, chemin 99272678, chemin 35444638, chemin 35444639, chemin 14794477, chemin 14794479, chemin 25535528, chemin 25535527, chemin 25535519, chemin 25535520, chemin 14794180, chemin 24625341, chemin 14794176, chemin 14794164, chemin 48405850, chemin 48405848, chemin 14787763, chemin 116730148, chemin 116730146, chemin 68445132, chemin 99272679, chemin 7253554, chemin 7256608, chemin 116730133, chemin 48966085, chemin 90667194, chemin 90087383, chemin 90087382, chemin 90087384, chemin 113730002, chemin 106201967, chemin 113729998, chemin 106201976, chemin 113730003, chemin 30979822, chemin 32804153, chemin 8074070, chemin 8074073, chemin 32804152, chemin 24500742, chemin 27762025, chemin 8074071, chemin 26258592, chemin 48966393, chemin 122127080, chemin 122127079, chemin 26258623, chemin 26258756, chemin 30979111, chemin 30979112, chemin 106225587, chemin 30963418, chemin 30963421, chemin 30963417, chemin 30963416, chemin 75116649, chemin 30963428, chemin 34327173, chemin 30963910, chemin 30963911, chemin 26613478, chemin 26613479, chemin 30963915, chemin 7744316, chemin 7744294, chemin 7742893, chemin 7742867, chemin 6229160, chemin 7743548, chemin 103006705, chemin 48536219, chemin 7743583, chemin 7743678, chemin 32319430, chemin 104290592, chemin 30198156, chemin 30277208, chemin 7745750, chemin 31435288, chemin 31435297, chemin 31435299, nœud 1148214240, nœud 1148214335, nœud 1045297714, nœud 1148259767, nœud 1148259772, nœud 1052233304, nœud 1052233298, nœud 1044227399]} is referenced by {Relation id=1557150 version=2 VT [relation 1421700, relation 1421675]} but not found in dataset
[NO DATASET] {Relation id=1448468 version=4 VT [chemin 30412403, chemin 103010195, chemin 50544724, chemin 22635252, chemin 8029559, chemin 53819724, chemin 27800220, chemin 27800216, chemin 48064923, chemin 27800128, chemin 27800118, chemin 4612504, chemin 28757093, chemin 62212146, chemin 48733277, chemin 8100579, chemin 4612600, chemin 8101453, chemin 94789594, chemin 94789604, chemin 4612251, chemin 8100561, chemin 4612367, chemin 31005203, chemin 99799957, chemin 99799956, chemin 4612655, chemin 94789602, chemin 94789593, chemin 4612657, chemin 5137140, chemin 62212155, chemin 62211498, chemin 50895233, chemin 104796443, chemin 103010188, chemin 62211499, chemin 5137104, chemin 62081489, chemin 62081515, chemin 62081452, chemin 50887018, chemin 30635627, chemin 99274480, chemin 99959831, chemin 23044717, chemin 22695283, chemin 2305547, chemin 30238112, chemin 23044698, chemin 99272680, chemin 4612302, chemin 97539206, chemin 38184731, chemin 99272684, chemin 28129644, chemin 28108102, chemin 28065151, chemin 28065152, chemin 2305718, chemin 28344747, chemin 80138220, chemin 4695565, chemin 4612670, chemin 80138218, chemin 80138219, chemin 4695534, chemin 77684340, nœud 1175048589, nœud 1155529422, nœud 1155529466, nœud 1155529439, nœud 1155529494, nœud 1155529339, nœud 1150978949, nœud 1155529489, nœud 1155529443, nœud 566643879, nœud 471004536, nœud 1175048620, nœud 1045297714, nœud 1148259767, nœud 1148259772, nœud 1155529463, nœud 1155529476, nœud 1175048549, nœud 1175048594, nœud 1175048613, nœud 1175048585]} is referenced by {Relation id=1557079 version=2 VT [relation 1448469, relation 1448468]} but not found in dataset


Plugin: cadastre-fr (26330)
Plugin: epci-fr (26282)
Plugin: licensechange (26377)
Plugin: restart (26254)

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(Unknown Source)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:84)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:125)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:310)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesTask$1.run(DownloadPrimitivesTask.java:82)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesTask.finish(DownloadPrimitivesTask.java:89)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:86)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.Dialog$1.run(Unknown Source)
	at java.awt.Dialog$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Don-vip

Description: modified (diff)
Resolution: irreproducible
Status: newclosed

Cannot reproduce anymore.

comment:2 Changed 7 years ago by Don-vip

Resolution: irreproducible
Status: closedreopened
Summary: NPE in dataset consistency testNPE when merging data

Got it while playing with reverter plugin:

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:409)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:358)
	at reverter.ChangesetReverter.downloadMissingPrimitives(ChangesetReverter.java:242)
	at reverter.RevertChangesetTask.checkAndDownloadMissing(RevertChangesetTask.java:55)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:75)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
	at java.lang.Thread.run(Thread.java:662)

comment:3 Changed 7 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 5758/josm:

fix #6630 - NPE when merging data

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.