Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6615 closed defect (fixed)

Error with licensechange plugin - missing error.gif?

Reported by: rasher Owned by: bastiK
Priority: normal Milestone:
Component: Plugin Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Click License Check and wait
  2. Crash

What is the expected result?

That the licensechange plugin works :)

What happens instead?

Crashes as shown by the attached dump. Pardon the Danish bits :-\

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-07-19 01:31:28
Last Changed Author: stoecker
Revision: 4257
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-18 12:00:06 +0200 (Mon, 18 Jul 2011)
Last Changed Rev: 4257

Identification: JOSM/1.5 (4257 da)
Memory Usage: 427 MB / 910 MB (141 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: DirectUpload (26284)
Plugin: ImportImagePlugin (26174)
Plugin: ImproveWayAccuracy (26224)
Plugin: OpeningHoursEditor (26284)
Plugin: buildings_tools (26254)
Plugin: editgpx (26284)
Plugin: licensechange (26373)
Plugin: openvisible (26174)
Plugin: restart (26254)
Plugin: videomapping (26254)
Plugin: waydownloader (26174)

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(Unknown Source)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:84)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:125)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException: Fatalt: Kunne ikke finde billede 'error.gif'. Dette er et alvorligt konfigurationsproblem. JOSM vil holde op med at virke.
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:92)
	at org.openstreetmap.josm.plugins.licensechange.ProblemTreeRenderer.getTreeCellRendererComponent(ProblemTreeRenderer.java:33)
	at javax.swing.plaf.basic.BasicTreeUI$NodeDimensionsHandler.getNodeDimensions(Unknown Source)
	at javax.swing.tree.AbstractLayoutCache.getNodeDimensions(Unknown Source)
	at javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.updatePreferredSize(Unknown Source)
	at javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.expand(Unknown Source)
	at javax.swing.tree.VariableHeightLayoutCache$TreeStateNode.expand(Unknown Source)
	at javax.swing.tree.VariableHeightLayoutCache.rebuild(Unknown Source)
	at javax.swing.tree.VariableHeightLayoutCache.treeStructureChanged(Unknown Source)
	at javax.swing.plaf.basic.BasicTreeUI$Handler.treeStructureChanged(Unknown Source)
	at javax.swing.tree.DefaultTreeModel.fireTreeStructureChanged(Unknown Source)
	at javax.swing.tree.DefaultTreeModel.nodeStructureChanged(Unknown Source)
	at javax.swing.tree.DefaultTreeModel.setRoot(Unknown Source)
	at org.openstreetmap.josm.plugins.licensechange.ProblemTreePanel.buildTree(ProblemTreePanel.java:228)
	at org.openstreetmap.josm.plugins.licensechange.ProblemTreePanel.setErrors(ProblemTreePanel.java:256)
	at org.openstreetmap.josm.plugins.licensechange.CheckAction$CheckTask$1.run(CheckAction.java:123)
	at org.openstreetmap.josm.plugins.licensechange.CheckAction$CheckTask.finish(CheckAction.java:130)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:86)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.Dialog$1.run(Unknown Source)
	at java.awt.Dialog$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by bastiK

Owner: changed from team to bastiK
Status: newassigned

comment:2 Changed 9 years ago by rasher

To clarify: It seems that things are actually working more or less as expected (nodes and ways are being marked in the layer), but this error pops up every now and then. There is no content in the "Relicensing problems" toolbox though. I don't know how it's supposed to work.

comment:3 Changed 9 years ago by bastiK

Resolution: fixed
Status: assignedclosed

In [4261/josm]:

fixed #6615 - Error with licensechange plugin - missing error.gif?

comment:4 Changed 9 years ago by bastiK

Ticket #6616 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.