Modify

Opened 9 years ago

Closed 9 years ago

#6613 closed defect (fixed)

JOSM 4223 interface bug with MacOS X

Reported by: padorange Owned by: padorange
Priority: major Milestone:
Component: Applet Version: tested
Keywords: Cc:

Description

Using lastest JOSM (4223) with MacOS X 10.6.8 broke the interface and i not usable.

The software launch and the main application bar appears for a second and then disappear : the startup screen seems normal and the button works.
But no window opens. If you use download button : nothing appears and any further click produce a beep (just press escape to exit the invisible window).
All windows are "invisible" so is the menu bar.

JOSM can't be used on MacOS X.

The same appears with Java Applet or MacOS X package.

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by bastiK

Can you name a recent version, that is not broken? No guessing, please try again.

http://josm.openstreetmap.de/download/

comment:2 in reply to:  1 Changed 9 years ago by padorange

Replying to bastiK:

Can you name a recent version, that is not broken? No guessing, please try again.

I've download several versions from archive (MacOS X package) and 4064 works fine (no interface problems, all windows works) : i've work last night with this version.

4221 is also broken.

comment:3 Changed 9 years ago by bastiK

It's a bit hard to do something without an environment to reproduce. If you can narrow the versions down further, I may be able to guess what the problem could be (but no promise).

You don't need a package, just download the jar and start like this: java -jar josm-(...).jar

The fact that this wasn't reported by other MacOS users, suggests that it might be specific to your configuration.

comment:4 Changed 9 years ago by padorange

OK i've downloaded and tested all the version available in download folder.

4138 is the last version that works fine.

from 4152 the interface is broken (invisible windows) and JOSM can't be used on my config.

I'll test on another Mac today.

My config :
iMac intel Core 2 Duo (MacOS X 10.6.8)

Java standard from Mac :
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03-384-10M3425)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02-384, mixed mode)

comment:5 Changed 9 years ago by stoecker

Owner: changed from team to padorange
Status: newneedinfo

Could it be that you have fullscreen mode enabled? In r4139 I fixed fullscreen mode, so it now works as expected. Later we turned it off for MacOS.

Is there a fullscreen menu item in display menu for you?

Does JOSM work fine, when you cleanup your settings?

comment:6 Changed 9 years ago by padorange

@stoecker : Yeah, you found the problem !

I've never see or used this option (fullscreen). I've checked in advanced preference (with 4064) and found "drawfullscreen = true" i put it to "false" and the run the lastest released and it works fine now.

This "fullscreen" option is now working with MacOS X at all.
Of course the application goes fullscreen but there is no menu bar (and no way for me to use it).
And it make all dialog window (open window, import, etc...) working (can close with ESC) but invisible.

Many thanks.

I don't know if the ticket has to be closed because the function seems to be strange and buggy for MacOS X.

comment:7 Changed 9 years ago by stoecker

Hmm, for MacOS this should be skipped totally in newest JOSM.

The question is why it is there? Do you have the Fullscreen menu item?

If yes, then MacOS detection is wrong. If no, then somehow fullscreen (not-)activation is wrong for MacOS.

comment:8 in reply to:  7 Changed 9 years ago by padorange

Replying to stoecker:

Hmm, for MacOS this should be skipped totally in newest JOSM.
The question is why it is there? Do you have the Fullscreen menu item?
If yes, then MacOS detection is wrong. If no, then somehow fullscreen (not-)activation is wrong for MacOS.

I don't see any "Fullscreen" in menus of sub-menus, neither a button (up to left)...
I just found the option in the preference panel "advanced parameters"...
And i have no clue why this option was "True", i don't think i do that myself...

comment:9 Changed 9 years ago by Xapitoun

I had the same problem. , I change the advanced preference, drawfullscreen and it works now. Thank you

comment:10 Changed 9 years ago by stoecker

Resolution: fixed
Status: needinfoclosed

In [4266/josm]:

fix #6613 - fullscreen action on MacOS still not fully disabled

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain padorange.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.