Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6596 closed defect (fixed)

Error on plugin ContourMerge 25626 instaled

Reported by: alexeys Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

At plugin ContourMerge 25626 install there is a following error at drawing of a simple line:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-07-11 01:31:35
Last Changed Author: stoecker
Revision: 4223
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-10 22:46:41 +0200 (Sun, 10 Jul 2011)
Last Changed Rev: 4223

Identification: JOSM/1.5 (4223 ru)
Memory Usage: 83 MB / 394 MB (36 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: DirectDownload (26174)
Plugin: DirectUpload (26284)
Plugin: ImageWayPoint (26174)
Plugin: ImportImagePlugin (26174)
Plugin: ImproveWayAccuracy (26224)
Plugin: PicLayer (26174)
Plugin: RoadSigns (26174)
Plugin: SimplifyArea (26224)
Plugin: colorscheme (26174)
Plugin: contourmerge (25626)
Plugin: dataimport (26174)
Plugin: download_along (26174)
Plugin: editgpx (26284)
Plugin: gpxfilter (26174)
Plugin: imageryadjust (26174)
Plugin: mapdust (26174)
Plugin: michigan_left (26174)
Plugin: multipoly-convert (26254)
Plugin: namemanager (26284)
Plugin: openstreetbugs (26299)
Plugin: openvisible (26174)
Plugin: public_transport (26284)
Plugin: reltoolbox (26299)
Plugin: restart (26254)
Plugin: reverter (26254)
Plugin: tageditor (26299)
Plugin: tagging-preset-tester (26174)
Plugin: turnrestrictions (26299)
Plugin: undelete (26254)
Plugin: utilsplugin2 (26295)
Plugin: walkingpapers (26299)
Plugin: waydownloader (26174)
Plugin: waypoint_search (26174)
Plugin: wayselector (26174)

java.lang.AbstractMethodError

at org.openstreetmap.josm.data.osm.event.PrimitivesAddedEvent.fire(PrimitivesAddedEvent.java:25)
at org.openstreetmap.josm.data.osm.DataSet.fireEventToListeners(DataSet.java:942)
at org.openstreetmap.josm.data.osm.DataSet.endUpdate(DataSet.java:921)
at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:346)
at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:50)
at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:53)
at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:36)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:58)
at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:508)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

You need to update to revision 1000. Maybe that requires deleting the plugin, as JOSM assumes 25626 is better than 1000.

See #6575.

comment:2 Changed 10 years ago by stoecker

Ticket #6605 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by anonymous

Ticket #6611 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.