Modify

Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#6552 closed defect (fixed)

terracer unnecessarily deletes objects in favour of new ones.

Reported by: skyper Owned by: zerebubuth@…
Priority: normal Milestone:
Component: Plugin terracer Version:
Keywords: terracer delete object history Cc: malenki

Description (last modified by skyper)

Terracer (with delete outer way set) deletes the ways and all nodes in favour of new objects. This is not needed.

  • The nodes do not have to bee deleted but could stay at there position and be used.
  • The outer way id could be used for the first closed way (building).

I mark this as major defect, because right now terracer produces too many new objects and destroys the history of objects by replacing them with new ones.

Attachments (0)

Change History (19)

comment:1 Changed 8 years ago by skyper

Description: modified (diff)

See also #7468

comment:2 Changed 7 years ago by skyper

Keeping the corner nodes is implemented

Outer way is still deleted and not changed.

Last edited 7 years ago by skyper (previous) (diff)

comment:3 Changed 7 years ago by Don-vip

Can you check this one today, too ? The changes I have made yesterday may have impacted this behaviour.

comment:4 in reply to:  3 Changed 7 years ago by skyper

Priority: majornormal

Replying to Don-vip:

Can you check this one today, too ? The changes I have made yesterday may have impacted this behaviour.

Did not change.

Still, if "delete outline" is checked, the way is deleted instead of reused as one part.

comment:5 Changed 5 years ago by stephan75

Is there any news on the last remaining topic of this ticket, namely keep the original way element of the building that is to be splitted as the "first" object of the new elements, so that it is "recycled"?

Because due to the big housenumber cleaning action in Germany taking place in these weeks of summer 2014 I came accross really many objects in German cities that need splitting.

comment:6 Changed 5 years ago by stephan75

I even found an example that splitting an OSM object in JOSM with re-use the original object is possible:

enable the utils_plugin2 and try the feature "Split object", for example draw a building with 4 corners, add two nodes on each longer sides of it, select these two nodes, and choose "split object" from menu More Tools.

result: old nodes AND old building way is re-used.

Is it possible at all to implement that code from utils-plugin2 to terracer plugin??

comment:7 Changed 5 years ago by stephan75

kindly asking:

Any progress on this ticket possible?

Because in these days I am fixing housenumbers in Mecklenburg-Vorpommern area in northern Germany, and I would really need the help of terracer plugin to split houses in parts.

Is it great effort to transfer the special logical code partly from "split object" feature (see above) to terracer plugin?

comment:8 in reply to:  7 Changed 5 years ago by skyper

Replying to stephan75:

kindly asking:

Any progress on this ticket possible?

Because in these days I am fixing housenumbers in Mecklenburg-Vorpommern area in northern Germany, and I would really need the help of terracer plugin to split houses in parts.

Is it great effort to transfer the special logical code partly from "split object" feature (see above) to terracer plugin?

Yeah, using terracer is realy cumbersome if you want to preserve history. That is why I mainly use "split object" and "replace geometry", both part of utilsPlugin2, though these to functions could be more flexible themselves, like supporting more than one split line or replacing any new node (id:0) an not only the one with only one parent.

comment:9 Changed 5 years ago by Don-vip

Ticket #10876 has been marked as a duplicate of this ticket.

comment:10 Changed 5 years ago by Don-vip

Cc: malenki added
Keywords: history added

comment:11 Changed 5 years ago by malenki

Wow, only three years old.
It seems both some programmers and some users care the same about keeping the history of OSM objects. :(

comment:12 Changed 5 years ago by Don-vip

That's not the point. 90% of plugin authors do not care about their plugin after a few months, leaving a ton of bugs to us :( We do not have enough resources to fix them accordingly.

comment:13 Changed 5 years ago by malenki

For me, it is the point – that the author of the tool couldn't think this far.
I don't blame the people who work their fingers off on JOSM.

comment:14 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

fixed in [o30872:30873]. Please test in a few minutes :)

comment:15 Changed 5 years ago by zerebubuth@…

So you're saying I must be either stupid or lazy? It's not surprising that you have trouble keeping maintainers with that attitude. :-(

In my case, I also didn't have enough time or resources to continue maintaining the plugin 5 years ago. I had a choice: to leave it unmaintained (as no one was willing to take over maintainership) or to delete it. Insults like these make me wish I had deleted it.

comment:16 in reply to:  13 Changed 5 years ago by stoecker

Replying to malenki:

For me, it is the point – that the author of the tool couldn't think this far.
I don't blame the people who work their fingers off on JOSM.

This is freely available open source software. Everybody does what he can and wants to do. I wont accept insults to anybody contributing to JOSM!

comment:17 Changed 5 years ago by Don-vip

Sorry I didn't want to offend you neither. I fully understand you may have no time anymore to work on the plugin. Still this is a good tool, that's why I try to fix the remaining bugs for the past two years... The problem is that nearly all plugins are in this situation, so that's a lot of work and it explains why tickets need several years before being looked at. We all have other stuff outside OSM, users tend to forget it :)

comment:18 Changed 5 years ago by malenki

@Don-vip: Thank you, it works!
@zerebubuth, stoecker: For me "didn't think far enough" does not imply nor mean "stupid" and thus is not an insult IMHO. Else you may consider I insulted and offended myself, too, because some years ago I also didn't care as much for "keeping the history" as I do today.
(btw: Some time ago I asked a mapper to be more careful for which his answer was "I am not careless!")

comment:19 Changed 5 years ago by zerebubuth@…

@malenki: I would have been OK with "didn't think far enough", because I'm pretty sure I didn't: I wrote terracer to scratch a particular itch with mapping in London and it turns out that most terraces have extremely irregular back sides and the amount of effort I saved from using terracer was very small. My workflow was always to draw a 'scaffold' shape over aerial imagery and then, immediately, terrace it. I didn't think far enough that people would apply terracer to shapes already saved in the database.

However, you said "couldn't think this far" which implies that you do blame me for what you suppose is my lack of ability to think: therefore "stupid or lazy". You say that wasn't your intention - OK. But as @stoeker says, this is open source software: it is frustrating when people (like me) don't maintain their software, but if everyone was expected to maintain software they released then I think that would mean far fewer people releasing software.

In summary: There's no point blaming anyone. The JOSM maintainers do a great job, and many thanks to them. And any time we meet someone who knows Java and wants to contribute to OSM code, we might suggest they start helping out with some of these old tickets.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain zerebubuth@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.