Modify

Opened 10 years ago

Closed 7 years ago

#6521 closed defect (duplicate)

add tag: problem with underscore in value

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: add tag underscore Cc:

Description (last modified by skyper)

Similar to #6430.
I have a Problem with underscore {_}.

  1. add tag leisure=swimming_pool to an object (do not know if it is in presets).
  2. add sports=swimming to a closed way.
  3. create a node and click on add (tag)
  4. change tag from sport to leisure and press {TAB} to jump to the value.
  5. value changes to "swimming_pool" but only "_pool" is highlighted and deleted using {Backspace}.

r4181

Attachments (0)

Change History (10)

comment:1 Changed 10 years ago by skyper

This was me

comment:2 Changed 10 years ago by Hojoe

This depends an the look and feel. With windows it works but with motif l&f it dosn't.

comment:3 Changed 10 years ago by Hojoe

Resolution: invalid
Status: newclosed

This is the behavior of the motif l&f.

comment:4 in reply to:  3 Changed 10 years ago by skyper

Description: modified (diff)
Resolution: invalid
Status: closedreopened

Replying to Hojoe <osm@…>:

This is the behavior of the motif l&f.

I have this behaviour with gtk on a linux system with openjdk.
Sorry, I mixed up the tickets but the link should be ok now.

This behaviour was introduced with the changes to add tag.

comment:5 Changed 10 years ago by anonymous

I can reproduce this bug with Metal, Nimbus and CDE/Motif l&f, but it works with windows l&f. For me it looks like a bug (or feature) in the l&f.

comment:6 Changed 9 years ago by Don-vip

Description: modified (diff)
Reporter: changed from anonymous to skyper

comment:7 Changed 9 years ago by skyper

Happened just yesterday with r5732 and Metal

comment:8 Changed 8 years ago by skyper

Description: modified (diff)

comment:9 Changed 8 years ago by mdk

I think this is not a problem with '_', but a more general behaviour of the auto complete function.
For more details see my comment in ticket:6430#comment:29.

comment:10 Changed 7 years ago by skyper

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #11048.
As 7883/josm fixing #6430 was not really complete the follow up is #11048.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.