Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6501 closed defect (fixed)

JOSM not working at all after updating plugins to latest version

Reported by: rickmastfan67 Owned by: team
Priority: blocker Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description

Now, before I updated the plugins, I was able to start r4164 just fine. But after I updated the plugins that were updated in [o26174] & [o26176], JOSM crashes when starting up and will not run at all, even when using r4170 which was released today!

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-25 01:31:45
Last Changed Author: stoecker
Revision: 4164
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-25 00:05:35 +0200 (Sat, 25 Jun 2011)
Last Changed Rev: 4164

Identification: JOSM/1.5 (4164 en)
Memory Usage: 122 MB / 3640 MB (100 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Plugin: OpeningHoursEditor
Plugin: RoadSigns
Plugin: alignways
Plugin: buildings_tools
Plugin: download_along
Plugin: imageryadjust
Plugin: mapdust
Plugin: measurement
Plugin: michigan_left
Plugin: openstreetbugs
Plugin: restart
Plugin: reverter
Plugin: turnlanes
Plugin: turnrestrictions
Plugin: undelete
Plugin: utilsplugin2

java.lang.NullPointerException
	at org.openstreetmap.josm.tools.I18n.load(I18n.java:562)
	at org.openstreetmap.josm.tools.I18n.addTexts(I18n.java:380)
	at org.openstreetmap.josm.plugins.PluginHandler.createClassLoader(PluginHandler.java:451)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:529)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:573)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:235)
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-26 01:31:44
Last Changed Author: stoecker
Revision: 4170
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-25 23:25:43 +0200 (Sat, 25 Jun 2011)
Last Changed Rev: 4170

Identification: JOSM/1.5 (4170 en)
Memory Usage: 122 MB / 3640 MB (98 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Plugin: OpeningHoursEditor
Plugin: RoadSigns
Plugin: alignways
Plugin: buildings_tools
Plugin: download_along
Plugin: imageryadjust
Plugin: mapdust
Plugin: measurement
Plugin: michigan_left
Plugin: openstreetbugs
Plugin: restart
Plugin: reverter
Plugin: turnlanes
Plugin: turnrestrictions
Plugin: undelete
Plugin: utilsplugin2

java.lang.NullPointerException
	at org.openstreetmap.josm.tools.I18n.load(I18n.java:562)
	at org.openstreetmap.josm.tools.I18n.addTexts(I18n.java:380)
	at org.openstreetmap.josm.plugins.PluginHandler.createClassLoader(PluginHandler.java:451)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:529)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:573)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:235)

Now, I was able to get JOSM to start up in r4170 (and r4164) if I completely deleted my entire plugin folder. But if I re-downloaded any plugins and restarted, JOSM wouldn't start again with the same error message above.

So, something in the recent plugin rebuilt really borked compatibility with JOSM to the point of making JOSM completely useless. Not good at all! This needs to be fixed ASAP, otherwise, you'll get TONS of bug reports on this one!

Attachments (1)

I18n.java.diff (1.5 KB) - added by motlib@… 10 years ago.
patch containing workaround for null-pointer problem.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by rickmastfan67

Update: I was able to revert all my plugins to versions that were released before [o26176]. Did that by going to the OSM Trac, finding, and then downloading the revision that was released before [o26176] for each plugin I use. So, now I have r4170 working with the old plugins again.

But still, if I were to try to update the plugins again (at this moment), I wouldn't be able to get JOSM to start. :(

On a side note, this brings up a possible future enhancement that would help when problems like this happen. See #6502.

comment:2 Changed 10 years ago by rickmastfan67

Ticket #6503 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by motlib@…

I can confirm the above mentioned bug:

Build-Date: 2011-06-26 11:11:14
Revision: 4170
Is-Local-Build: true

Identification: JOSM/1.5 (4170 SVN en)
Memory Usage: 15 MB / 494 MB (6 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Plugin: buildings_tools
Plugin: measurement
Plugin: tageditor
Plugin: terracer
Plugin: turnrestrictions
Plugin: utilsplugin2

java.lang.NullPointerException

at org.openstreetmap.josm.tools.I18n.load(I18n.java:562)
at org.openstreetmap.josm.tools.I18n.addTexts(I18n.java:380)
at org.openstreetmap.josm.plugins.PluginHandler.createClassLoader(PluginHandler.java:451)
at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:529)
at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:573)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:235)

Made a quick fix to I18n.java to work around this bug by never setting the strings and pstrings hashtables to null. But this is only a workaround, I18n.java should be modified further to remove now unnecessary "== null" comparisons. I hope the following svn diff output can be applied not only to my sources, I have never yet worked with diff and patch. Output of "svn diff ./src/org/openstreetmap/josm/tools/I18n.java" is attached.

Changed 10 years ago by motlib@…

Attachment: I18n.java.diff added

patch containing workaround for null-pointer problem.

comment:4 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4171/josm]:

fix #6501 - NPE for english language version

comment:5 Changed 10 years ago by stoecker

I rebuilt josm, please update.

comment:6 Changed 10 years ago by rickmastfan67

Just updated to r4171. Then re-updated the plugins to latest version again and all works correctly. :)

Thank you for fixing this. :)

On a side note, shouldn't the plugins be updated to mention a minimum version of r4171 now? Don't want people being updated to the newest plugins if they are still using the "tested" build of r4064 (or any other pre-r4171) and have this same problem, right? ;)

Last edited 10 years ago by rickmastfan67 (previous) (diff)

comment:7 Changed 10 years ago by stoecker

No. The plugins are downwards compatible.

comment:8 Changed 10 years ago by rickmastfan67

If they were downwards compatible, why wouldn't they work in r4164 then? That's the version I had running first when I updated the plugins to [o26174] (see original report). Only then did I try updating to r4170.

This NPE happened in both r4164 and r4170. Hence why I think the plugins need to have the minimum version of r4171.

Last edited 10 years ago by rickmastfan67 (previous) (diff)

comment:9 Changed 10 years ago by stoecker

Because the bug was introduced in core revision r4159 and thus all core version between r4159 and r4171 will fail.

comment:10 Changed 10 years ago by rickmastfan67

Ah, ok. Thanks for clearing that up for me. :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.