Modify

Opened 10 years ago

Closed 10 years ago

#6476 closed defect (fixed)

Fully automatic OAuth does not work

Reported by: Claudius Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: OAuth Cc:

Description

Rev4138

  • Started with a blank preferences file
  • tried fully automatic OAuth setup in preferences.
  • Result was a window stating that JOSM could not login at www.openstreetmap with the credentials supplied although they are correct and have been tested to be working

org.openstreetmap.josm.gui.oauth.OsmLoginFailedException

at org.openstreetmap.josm.gui.oauth.OsmOAuthAuthorizationClient.authenticateOsmSession(OsmOAuthAuthorizationClient.java:351)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Cobra

I can confirm this for r4143. Semi-Automatic works fine, though.

comment:2 Changed 10 years ago by stoecker

Very likely OSM changed login procedure.

comment:3 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4147/josm]:

fix #6476 - fully automatic oauth failing due to server changes

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.