Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6460 closed defect (duplicate)

validator: NPE fixing "Mixed type duplicated nodes - Duplicated nodes"

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report validator fix NPE Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. I had duplicated nodes and validator did warn (there is something weired in JOSM. Do not know if it is following line or something else).
  2. Deleted one unconnected, untaged node.
  3. Select the subcategory "Mixed type duplicated nodes - Duplicated nodes"
  4. Click on fix

What is the expected result?

The duplicated nodes are fixed

What happens instead?

NPE

Please provide any additional information below. Attach a screenshot if
possible.

The problem is again, that validator has a problem if one object does not exist anymore.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-11 01:31:38
Last Changed Author: bastiK
Revision: 4135
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-11 01:17:42 +0200 (Sat, 11 Jun 2011)
Last Changed Rev: 4135

Identification: JOSM/1.5 (4135 en)
Memory Usage: 128 MB / 248 MB (30 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: Curves (16.master-4f7c5a0)
Plugin: OpeningHoursEditor (26002)
Plugin: ParallelWay (14.master-76832fe)
Plugin: alignways (25199)
Plugin: buildings_tools (25905)
Plugin: multipoly-convert (25192)
Plugin: reltoolbox (26125)
Plugin: reverter (26093)
Plugin: terracer (26029)
Plugin: undelete (26073)
Plugin: utilsplugin2 (26051)
Plugin: waydownloader (25190)

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
	at org.openstreetmap.josm.gui.dialogs.ValidatorDialog$FixTask.realRun(ValidatorDialog.java:582)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1045)
	at javax.swing.SwingUtilities.invokeAndWait(SwingUtilities.java:1351)
	at org.openstreetmap.josm.gui.dialogs.ValidatorDialog$FixTask.realRun(ValidatorDialog.java:557)
	... 8 more
Caused by: java.lang.IllegalArgumentException: {Node id=-2180 version=0 MVD lat=47.98972711659008,lon=7.84759979203442} is already deleted
	at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:117)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:53)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:36)
	at org.openstreetmap.josm.gui.dialogs.ValidatorDialog$FixTask$1.run(ValidatorDialog.java:560)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1492)
	at java.awt.Component.setVisible(Component.java:1444)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by skyper

Component: CoreCore validator

comment:2 Changed 10 years ago by skyper

Description: modified (diff)
Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by skyper

Closed as duplicate of #5773.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.