Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6440 closed defect (fixed)

[Patch] do not render barrier=* without area=yes as areas

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version:
Keywords: barrier render area Cc:

Description

Please, do not render closed ways with barrier=* (fence,wall,...) without area=yes as areas

Thanks

Attachments (1)

6440.patch (2.8 KB) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by Claudius

I like the filled rendering of closed barrier=*-areas as it reflects that access to the inner section is limited by the barrier. I vote for leaving it as is.

comment:2 in reply to:  1 Changed 8 years ago by skyper

Replying to claudius.h@…:

I like the filled rendering of closed barrier=*-areas as it reflects that access to the inner section is limited by the barrier. I vote for leaving it as is.

But that is simply wrong. Like highways barriers are drawn as lines and if you want to state that the barrier is an area you have to add area=yes to the closed way.

For access definition use access=* .

comment:3 Changed 8 years ago by skyper

Ticket #5782 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by Zverikk

I second this. Usually I filter out all features that cover imagery, making it difficult to trace: leisure, natural, place etc. It would be strange having to hide barrier=* also, as it doesn't denote area feature.

comment:5 Changed 8 years ago by simon04

I would consider it more natural to not render the area of a barrier in general. This also corresponds to Mapnik's rendering.

Changed 8 years ago by simon04

Attachment: 6440.patch added

comment:6 Changed 8 years ago by simon04

Summary: do not render barrier=* without area=yes as areas[Patch] do not render barrier=* without area=yes as areas

According to Taginfo, area is used only in 0.34% cases together with barrier. Thus, I would not handle this combination specially.

Patch attached to remove the area style …

comment:7 in reply to:  6 Changed 8 years ago by skyper

Replying to simon04:

According to Taginfo, area is used only in 0.34% cases together with barrier. Thus, I would not handle this combination specially.

The percentage almosts doubles if you do not count nodes into it. Though still tiny.

area=yes is not used cause even mapnik did not render it correct until some month ago and it will not get used in JOSM if it is not rendered.

comment:8 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In [4444/josm]:

fix #6440 - do not render barrier=* without area=yes as areas

comment:9 Changed 8 years ago by skyper

Thanks a lot !

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.