Modify

Opened 8 years ago

Closed 8 years ago

#6436 closed enhancement (fixed)

[PATCH] Changing power_source preset to generator:source

Reported by: Claudius Owned by: ce
Priority: normal Milestone:
Component: Internal preset Version:
Keywords: Cc:

Description

Currently the preset for power=generator contains the power_source-tag for specifying the generator's source. More than a year ago the power tagging scheme was overhauled and generator:source is suggested and documented in the wiki [1]. Apart from that the latter is already used more widely in the database [2] than power_source.

The attached patch replaces power_source in the JOSM preset with generator:source and adds generator:method and generator:output as well.

[1] http://wiki.openstreetmap.org/wiki/Key:generator:method
[2] http://taginfo.openstreetmap.de/keys/generator:source#values
[3] http://taginfo.openstreetmap.de/keys/power_source#values

Attachments (1)

generator_source.patch (1.1 KB) - added by Claudius 8 years ago.
Patch to replace power_source with generator:source in the preset

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Claudius

Attachment: generator_source.patch added

Patch to replace power_source with generator:source in the preset

comment:1 Changed 8 years ago by anonymous

Ticket #6434 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by Don-vip

Ticket #6420 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by Schusch

please add this patch to josm ... long time missing feature

comment:4 Changed 8 years ago by bastiK

Resolution: fixed
Status: newclosed

In [4210/josm]:

applied #6436 - Changing power_source preset to generator:source (patch by claudius.h)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ce.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.