Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#6392 closed enhancement (duplicate)

Opening the preferences dialog is too slow

Reported by: olejorgenb Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: preferences dialog, preferences, performance Cc:

Description (last modified by Don-vip)

On my admittedly not very beefy hardware, the dialog needs 3-5s to show. First invocation is somewhat slower than subsequent ones.

I looked briefly at the code, and ran the jrat profiler, but I don't see any single offender, so I assume that the initial run-time more or less is required.

The dialog is created from scratch each time though, and a lot of the work are initializations. (eg. generate valid keyboard keys)

Simply caching the dialog instance doesn't cause any fatal problems. This also has the nice side effect of remembering where you where in the dialog last time.

Complications occurs when settings are changed externally though. Eg. if I add a imagery offset bookmark, this does not show in the cached dialog.

I guess no-one is very motivated to solve a issue that's getting less and less serious, and is mostly annoying to new users? :) (I poke a lot in the preferences of new applications at least)

Depending on how many cases like the imagery offset there is, I don't think it should be too much work to fix. Not that fun though.

Ps: Sorry if this has been discussed. I only found https://josm.openstreetmap.de/ticket/3693 (not impressed with the track search so far..)

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by skyper

+1

Have the same problems with old machines. The memory use is quite big, too.
On a low resolution screen you also have to scroll down sometimes !

I always wondered why there is no link or even dialog for settings within the top menus (e.g. imagery, cadastre).

Cheers

comment:2 Changed 11 years ago by bastiK

Another option would be to load each tab, when it is clicked.

comment:3 Changed 10 years ago by Don-vip

Description: modified (diff)
Resolution: duplicate
Status: newclosed

comment:4 Changed 10 years ago by Don-vip

Closed as duplicate of #7386.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.