Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#6367 closed defect (fixed)

[PATCH]Select last node of way when undoing Follow Line

Reported by: Manchito Owned by: team
Priority: normal Milestone: 14.05
Component: Core Version: latest
Keywords: undo follow line Cc:

Description (last modified by stoecker)

  1. Extend a line with Follow Line
  2. Undo the last action
  3. Try to use Follow Line again
  4. Crash

Attachments (2)

undo_crash.patch (1.7 KB) - added by Manchito 9 years ago.
JOSM.patch (5.6 KB) - added by landwirt@… 9 years ago.
patch for undoing Follow Line

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by Manchito

Attachment: undo_crash.patch added

comment:1 Changed 9 years ago by stoecker

Summary: Crash when using Follow Line action after undo[patch] Crash when using Follow Line action after undo

I think this patch fixes symptoms instead of real cause.

comment:2 Changed 9 years ago by bastiK

Undo is a little strange for follow line:

  • Press F a few times
  • Ctrl-Z --> rubber line vanishes
  • Ctrl-Z repeatedly until you reach the first node --> rubber line comes back and is attached to the (still selected) last node

I think it would be best, if undo moved the rubber line back node by node.

comment:3 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4111/josm]:

fix #6367 - patch by Manchito - fix NPE

comment:4 Changed 9 years ago by stoecker

@Manchito:
Please no formatting changes in patches.

@bastiK:
That is an normal DrawAction issue, as the last node of a ChangeCommand stays selected. But currently we do not do real selection handling in Undo/Redo. I do not know if it is a good idea to introduce this. It could take a lot of memory and bring little benefits. But maybe we can link the existing SelectionHistory to Undo/Redo, so in case we have a selection history we can use it.

comment:5 Changed 9 years ago by skyper

Resolution: fixed
Status: closedreopened
Summary: [patch] Crash when using Follow Line action after undoSelect last node of way when undoing Follow Line (WAS:Crash when using Follow Line action after undo)
Type: defectenhancement

Would be nice if the selected node would change to the last node of the way.

Right now I often only miss a "crossing" by one or two nodes and hit undo. If have to manually select the last node to continue drawing which means changing modes twice.

Thanks

comment:6 Changed 9 years ago by landwirt@…

Summary: Select last node of way when undoing Follow Line (WAS:Crash when using Follow Line action after undo)Select last node of way when undoing Follow Line
Type: enhancementdefect

Letting the undo command select the last node is an expected behavior, doing not so is clearly a defect.

Changed 9 years ago by landwirt@…

Attachment: JOSM.patch added

patch for undoing Follow Line

comment:7 Changed 9 years ago by landwirt@…

Summary: Select last node of way when undoing Follow Line[PATCH]Select last node of way when undoing Follow Line

With the new patch josm sets the selection to the last node after undoing Follow Line. Feel free to test it.

comment:8 Changed 8 years ago by stoecker

Description: modified (diff)

This patch looks like it has been overlooked. Anyone tested it?

comment:9 Changed 8 years ago by skyper

Any news ?

comment:10 Changed 7 years ago by skyper

Another six month have passed.

comment:11 Changed 7 years ago by skyper

ping

This is really annoying and the patch is waiting over 21 month for review now.

comment:12 Changed 6 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 7122/josm:

fix #6367 - Select last node of way when undoing Follow line (patch by Landwirt, updated, modified)

comment:13 Changed 6 years ago by Don-vip

Milestone: 14.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.