Modify

Opened 8 years ago

Closed 6 years ago

#6313 closed defect (fixed)

validator: false positive in "Way end node near other highway"

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.01
Component: Core validator Version: latest
Keywords: unconnected_way false positive Cc:

Description (last modified by skyper)

I attach a file.

The node is connected with the highway via another highway. There should be no warning at all.

r4073

Attachments (2)

validator_WayEndNodeNearHighway_example.osm (2.7 KB) - added by skyper 8 years ago.
example file
6313_example.osm (1.8 KB) - added by Don-vip 6 years ago.
additional example

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by skyper

example file

comment:1 Changed 8 years ago by simon04

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by simon04

Closed as duplicate of #3531.

comment:3 Changed 8 years ago by skyper

Resolution: duplicate
Status: closedreopened

Is it he same code ?

Cause in this case the ways are connected but through another way, where #3531 is about a highway and a waterway.

comment:4 Changed 8 years ago by skyper

Description: modified (diff)
Keywords: unconnected added; end node highway validator removed

comment:5 Changed 8 years ago by skyper

Keywords: unconnected_way added; unconnected way removed

comment:6 Changed 6 years ago by skyper

Please, this is really annoying as short ways between a intersection and a bridge for example are always reported and user lead to only use one node (bridge end node + intersection) instead which is wrong and renders ugly.

Changed 6 years ago by Don-vip

Attachment: 6313_example.osm added

additional example

comment:7 Changed 6 years ago by Don-vip

Milestone: 14.01

comment:8 Changed 6 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 6556/josm:

fix #6313 - validator, UnconnectedWays: handle intersections of t shapes and similar

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.