Modify

Opened 8 years ago

Closed 8 years ago

Last modified 3 years ago

#6301 closed defect (fixed)

Check for null mandatory in TableCellRenderer.getTableCellRendererComponent

Reported by: jttt Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

For unknown reason java sometimes call getTableCellRendererComponent method with value = null. It's called from method javax.swing.JTable$AccessibleJTable.getAccessibleChild. See http://stackoverflow.com/questions/3054775/java-swing-jtable-strange-behavior-from-getaccessiblechild-method-resulting-i for little more details.

Every implementation of getTableCellRendererComponent must fail gracefully when null is passed as value paramater.

Attachments (0)

Change History (16)

comment:1 Changed 8 years ago by jttt

Ticket #6271 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by jttt

Ticket #6258 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by jttt

Ticket #6176 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by jttt

Ticket #6105 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by jttt

Ticket #5928 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by jttt

Ticket #5854 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by jttt

Ticket #5771 has been marked as a duplicate of this ticket.

comment:8 Changed 8 years ago by jttt

Ticket #5689 has been marked as a duplicate of this ticket.

comment:9 Changed 8 years ago by jttt

Ticket #5573 has been marked as a duplicate of this ticket.

comment:10 Changed 8 years ago by bastiK

Good to know, this certainly explains some things...

comment:11 Changed 8 years ago by jttt

Resolution: fixed
Status: newclosed

In [4072/josm]:

Fix #6301 Check for null mandatory in TableCellRenderer.getTableCellRendererComponent

comment:12 Changed 8 years ago by Don-vip

Ticket #6408 has been marked as a duplicate of this ticket.

comment:13 Changed 3 years ago by bastiK

In 10016/josm:

fixed #12650 - Error when click on Imagery providers (see #6301)

comment:14 Changed 3 years ago by bastiK

In 10020/josm:

see #6301 - add test that checks TableCellRenderer.getTableCellRendererComponent with null argument

scans classpath to find all classes implementing TableCellRenderer interface

comment:15 Changed 3 years ago by bastiK

In 10021/josm:

see #6301 - fix issues detected by the test

comment:16 Changed 3 years ago by Don-vip

In 10023/josm:

see #6301 - update .classpath

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.