Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6272 closed enhancement (duplicate)

Extend fuel preset dial for payment methods

Reported by: flaimo Owned by: team
Priority: minor Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

the preset dialog for fuel stations should offer checkboxes for payment methods using the notation for the new payment keys as stated on the wiki page: http://wiki.openstreetmap.org/wiki/Key:payment

the entries under the following sections from the wiki page make sense to be includes in the dialog: cash, debit cards, credit cards, fuel cards

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by flaimo

ok, i went through the preset xml. i think the following payment lines should be added or replace the old ones:

item name="Fuel"

      <space />
      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <check key="payment:cash" text="Cash (Shortcut for Coins and Notes)" default="on" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />
      <space />
     <label text="Payment methods: Fuel cards" />
      <check key="payment:dkv" text="DKV" default="off" />
      <check key="payment:uta" text="UTA" default="off" />
      <check key="payment:routex" text="Routex" default="off" />
      <check key="payment:roadrunner" text="Roadrunner" default="off" />
      <check key="payment:svg" text="SVG" default="off" />

item name="Ticket Machine"

      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />
      <space />
      <label text="Payment methods: Public transport" />
      <check key="payment:oyster" text="Oyster" default="off" />
      <check key="payment:bob" text="Bob" default="off" />

item name="Telephone"

      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />
      <space />
      <label text="Payment methods: Other" />
      <check key="payment:telephone_card" text="Telephone card" default="off" />

item name="Vending machine"

      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />

comment:2 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by stoecker

Closed as duplicate of #6268.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.