Modify

Opened 11 years ago

Closed 11 years ago

#623 closed defect (wontfix)

JOSM doesn`t download nested relations

Reported by: AkMeR Owned by: framm
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When one relation is a member of another relation (e.g. Relations/Proposed/Postal Addresses), JOSM doesn`t download this relation (which is a member).

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by AkMeR

Priority: majorcritical
Type: enhancementdefect
Version: releaselatest

As its described in API 0.5:
Resolving Forward References

You can retrieve an object and all objects referenced by it.

GET /api/0.5/<objtype>/<id>/full

This call is available for an <objtype> of way or relation. For a way, it will return the way specified plus the full XML of all nodes referenced by the way. For a relation, it will return the following:
the relation itself
all nodes, ways, and relations that are members of the relation
plus all nodes used by ways from the previous step.

The same recursive logic is not applied to relations. This means: If relation r1 contains way w1 and relation r2, and w1 contains nodes n1 and n2, and r2 contains node n3, then a "full" request for r1 will give you r1, r2, w1, n1, and n2. Not n3.

When I manully retrieve relation, for example by typing in browser http://api.openstreetmap.org/api/0.5/relation/5677/full, the server returns all relations, that referenced by relation 5677.
But JOSM doesn`t! It only returns relations assigned to objects in current bounding box!

comment:2 Changed 11 years ago by framm

Resolution: wontfix
Status: newclosed

This is not a bug. JOSM uses the "map" API call and loads exactly the relations returned by it. Automatically following references could be potentially dangerous (generating huge downloads e.g. if you happen to download part of a national cycle route relation or so).

Agree that relation handling in JOSM is not optimal and needs a lot of attention; maybe we will have an option for the user to manually request following certain links set up by relations.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.