Modify

Opened 11 years ago

Closed 11 years ago

#6050 closed defect (fixed)

render bug with ways, strange lines (WAS: render bug with selected way)

Reported by: skyper Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: render way line Cc:

Description

I get a huge render bug when selecting all members of a national road (Bundesstraße) in low zoom level. If I zoom in it is better but still some errors.
I attach a osm-file and a screenshot

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-03-03 02:31:30
Last Changed Author: bastiK
Revision: 3948
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-03-02 19:03:33 +0100 (Wed, 02 Mar 2011)
Last Changed Rev: 3948

Identification: JOSM/1.5 (3948 en)
Memory Usage: 60 MB / 241 MB (19 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: cadastre-fr (25192)
Plugin: utilsplugin2 (25190)

Attachments (9)

Render_Error_6050.osm (187.0 KB) - added by skyper 11 years ago.
osm
Render_Error_6050_low_zoom.png (153.6 KB) - added by skyper 11 years ago.
screenshot
Render_Error_6050_higher_zoom.png (169.7 KB) - added by skyper 11 years ago.
screenshot 2
render_example.osm (1.2 KB) - added by anonymous 11 years ago.
osm 1
render_example2.osm (1.0 KB) - added by anonymous 11 years ago.
osm 2
render_example3.osm (458 bytes) - added by anonymous 11 years ago.
osm 3
renderbug.png (9.7 KB) - added by anonymous 11 years ago.
screenshot 1
renderbug2.png (10.7 KB) - added by anonymous 11 years ago.
screenshot 2
renderbug3.png (5.5 KB) - added by anonymous 11 years ago.
screenshot 3

Download all attachments as: .zip

Change History (26)

Changed 11 years ago by skyper

Attachment: Render_Error_6050.osm added

osm

Changed 11 years ago by skyper

screenshot

Changed 11 years ago by skyper

screenshot 2

comment:1 Changed 11 years ago by skyper

looks like this

screenshot

comment:2 Changed 11 years ago by bastiK

Cannot reproduce.

There is probably some setting that triggers the bug. Try to start with fresh configuration

java -Djosm.home=$HOME/.josm-new -jar josm-latest.jar

comment:3 in reply to:  2 Changed 11 years ago by skyper

Replying to bastiK:

Cannot reproduce.

There is probably some setting that triggers the bug. Try to start with fresh configuration

java -Djosm.home=$HOME/.josm-new -jar josm-latest.jar

I check on Ubuntu 10.10 and everything was fine but for the Debian squeeze it did not help. I also totally reinstalled open-jdk, but nothing different

Build-Date: 2011-03-07 02:31:27
Last Changed Author: mjulius
Revision: 3961
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-03-06 22:06:57 +0100 (Sun, 06 Mar 2011)
Last Changed Rev: 3961

Identification: JOSM/1.5 (3961 de)
Memory Usage: 36 MB / 367 MB (11 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

comment:4 Changed 11 years ago by bastiK

Please add more information that could help to diagnose the problem. Does it happen on all ways, all the time, etc.

Try draw.segment.head_only=false. Is it still the same?

comment:5 in reply to:  4 ; Changed 11 years ago by skyper

Replying to bastiK:

Please add more information that could help to diagnose the problem. Does it happen on all ways, all the time, etc.

It happens on many ways (but sometimes you have to zoom way out). I just tried it with a new way with only 2 nodes and no tags.

Try draw.segment.head_only=false. Is it still the same?

yes

comment:6 Changed 11 years ago by skyper

Sorry, seems to happen with all ways.
It happens with only one way selected and it does not matter if the way is closed or not.

the bug was introduced between r3888 and r3891. It works with r3887.

Hope that helps.

comment:7 in reply to:  5 ; Changed 11 years ago by bastiK

Replying to skyper:

Replying to bastiK:

Please add more information that could help to diagnose the problem. Does it happen on all ways, all the time, etc.

It happens on many ways (but sometimes you have to zoom way out). I just tried it with a new way with only 2 nodes and no tags.

Try draw.segment.head_only=false. Is it still the same?

yes

You get a line with one arrow when selected, but still there is a line to (0,0) for each node? That would be surprising...

comment:8 in reply to:  6 Changed 11 years ago by bastiK

Replying to skyper:

Sorry, seems to happen with all ways.
It happens with only one way selected and it does not matter if the way is closed or not.

the bug was introduced between r3888 and r3891. It works with r3887.

That's helpful, probably [3889]; note to self: The trigger could be omitted rounding for the arrow coordinates or

g.setStroke(new BasicStroke(line.getLineWidth(), line.getEndCap(), BasicStroke.JOIN_MITER, line.getMiterLimit()));

before drawing the arrows.

Hope that helps.

It's hard to investigate on a platform where the bug does not occur. [3889] looks fine to me, so basically this is all I can do at the moment. If you are into it, you could try to debug yourself.

comment:9 in reply to:  7 Changed 11 years ago by skyper

Keywords: way added
Summary: render bug with several objects selectedrender bug with selected way

Replying to bastiK:

Replying to skyper:

Replying to bastiK:

Please add more information that could help to diagnose the problem. Does it happen on all ways, all the time, etc.

It happens on many ways (but sometimes you have to zoom way out). I just tried it with a new way with only 2 nodes and no tags.

Try draw.segment.head_only=false. Is it still the same?

yes

You get a line with one arrow when selected, but still there is a line to (0,0) for each node? That would be surprising...

No I get an extra line from last node to (0,0).

The lines do appear one by one zooming out when several ways are selected. It is easy to miss with only one or two ways seleccted because you have to zoom way out.

Last edited 11 years ago by skyper (previous) (diff)

comment:10 Changed 11 years ago by skyper

Now I have the same issue on another system (ubuntu)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-03-20 02:31:26
Last Changed Author: mjulius
Revision: 3995
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-03-20 01:29:48 +0100 (Sun, 20 Mar 2011)
Last Changed Rev: 3995

Identification: JOSM/1.5 (3995 en)
Memory Usage: 642 MB / 1820 MB (240 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: ColumbusCSV (25192)
Plugin: cadastre-fr (25192)
Plugin: colorscheme (25192)
Plugin: openstreetbugs (25540)
Plugin: public_transport (25192)
Plugin: tageditor (25191)
Plugin: toms (23605)
Plugin: undelete (25199)
Plugin: wms-turbo-challenge2 (25191)

This time it happens even with unselected closed ways (forest)

comment:11 Changed 11 years ago by bastiK

If you can compile josm yourself, you can do a partial revert of [3889] and see what happens.

comment:12 Changed 11 years ago by rab

Same problem here with Mandriva 10.2 64 bit.
First the error occured only with selected ways.
Now all the ways are affected.
Handling is also significantly slower.
On my laptop with Mandriva i586, JOSM performes completly normal.

comment:13 Changed 11 years ago by skyper

Keywords: line added; select removed
Summary: render bug with selected wayrender bug with ways, strange lines (WAS: render bug with selected way)

Changed title as the problem appears even with unselected ways.

comment:14 Changed 11 years ago by skyper

Now it gets even into data.

screenshot 1

If I delete the node in the north (which is faulty) I get a way with 5 nodes as one node is still listed twice:

screenshot 2

if I cut the way where the line goes of I get a way containing twice the same node:

screenshot 3

I attach all three osm-files.

Last edited 11 years ago by skyper (previous) (diff)

Changed 11 years ago by anonymous

Attachment: render_example.osm added

osm 1

Changed 11 years ago by anonymous

Attachment: render_example2.osm added

osm 2

Changed 11 years ago by anonymous

Attachment: render_example3.osm added

osm 3

Changed 11 years ago by anonymous

Attachment: renderbug.png added

screenshot 1

Changed 11 years ago by anonymous

Attachment: renderbug2.png added

screenshot 2

Changed 11 years ago by anonymous

Attachment: renderbug3.png added

screenshot 3

comment:15 Changed 11 years ago by bastiK

this is completely unrelated

comment:16 Changed 11 years ago by bastiK

Please check if it is gone with [4042].

For the second bug, it looks interesting, please open another ticket.

comment:17 in reply to:  16 Changed 11 years ago by skyper

Resolution: fixed
Status: newclosed

Replying to bastiK:

Please check if it is gone with [4042].

Yes, thanks a lot.
I check just one example, so far but this one works with r4054 and it did not with r4041.

For the second bug, it looks interesting, please open another ticket.

I did: #6234

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.