Modify

Opened 11 years ago

Closed 11 years ago

#6036 closed defect (fixed)

JOSM expected to find primitive [node 18963] in dataset but it is not there.

Reported by: jBeata Owned by: team
Priority: normal Milestone:
Component: Plugin openstreetbugs Version:
Keywords: Cc:

Description

After zooming in/out and selecting an Openstreetbug from the bugs list, the following error appears on the terminal window:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-02-28 02:31:27
Last Changed Author: bastiK
Revision: 3936
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-02-27 13:33:37 +0100 (Sun, 27 Feb 2011)
Last Changed Rev: 3936
GET http://api.openstreetmap.org/api/capabilities... OK
Communications with http://api.openstreetmap.org/api established using protocol version 0.6.
loading plugin 'openstreetbugs' (version 25199)
loading plugin 'mapdust' (version 25312)
Open file: /home/bjancso/Desktop/file1.osm (6629928 bytes)
Keystroke shift alt pressed A is already assigned to org.openstreetmap.josm.gui.dialogs.ToggleDialog$ToggleDialogAction@5dbb6a69, will be overridden by org.openstreetmap.josm.gui.dialogs.ToggleDialog$ToggleDialogAction@75157f77
Silent shortcut conflict: 'view:openstreetbugs' moved by 'system:download_primitive' to 'Ctrl+Alt+O'.

JOSM expected to find primitive [node 18963] in dataset but it is not there. Please report this at http://josm.openstreetmap.de . This is not a critical error, it should be safe to continue in your work.
java.lang.Exception

at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveByIdChecked(DataSet.java:706)
at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:545)
at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:487)
at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:507)
at org.openstreetmap.josm.plugins.osb.gui.OsbDialog.valueChanged(OsbDialog.java:294)
at javax.swing.JList.fireSelectionValueChanged(JList.java:1782)
at javax.swing.JList$ListSelectionHandler.valueChanged(JList.java:1796)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:184)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:164)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:211)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:405)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:415)
at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:459)
at javax.swing.JList.setSelectionInterval(JList.java:2052)
at javax.swing.plaf.basic.BasicListUI$Handler.adjustSelection(BasicListUI.java:2729)
at javax.swing.plaf.basic.BasicListUI$Handler.mousePressed(BasicListUI.java:2685)
at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:279)
at java.awt.Component.processMouseEvent(Component.java:6105)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:5873)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4122)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by stoecker

Component: CorePlugin openstreetbugs

comment:2 Changed 11 years ago by hampelratte

This probably happens during the update process, when the list content is not yet updated, so that it displays an inconsistent state. In this case it may happen, that the lists shows a bug/node, which does not exist in the new dataset, because it left the bounds of the visible rectangle. I have added some code, which disables the list during the update process. Hopefully this fixes the problem.

comment:3 Changed 11 years ago by jBeata

This happens, when you move the map, and then select an element from the list of OpenStreetBugs. Maybe the list contains elements which are not visible anymore on the map.

comment:4 Changed 11 years ago by jBeata

Resolution: fixed
Status: newclosed

This issue cannot be reproduced anymore.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.