Modify

Opened 9 years ago

Closed 7 years ago

#6004 closed defect (fixed)

Dialog was already created execeptiom

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc: dcp

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. start josm
  2. try to download data via josm remote or manual

Some error

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-31 02:31:28
Last Changed Author: bastiK
Revision: 3751
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-30 16:31:05 +0100 (Thu, 30 Dec 2010)
Last Changed Rev: 3751

Identification: JOSM/1.5 (3751 en)
Memory Usage: 36 MB / 247 MB (8 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Plugin: AddrInterpolation
Plugin: CommandLine
Plugin: OpeningHoursEditor
Plugin: PicLayer
Plugin: SimplifyArea
Plugin: buildings_tools
Plugin: graphview
Plugin: openstreetbugs
Plugin: public_transport
Plugin: reverter
Plugin: routes
Plugin: routing
Plugin: tagging-preset-tester
Plugin: turnrestrictions

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(Unknown Source)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:88)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalStateException: Dialog was already created
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog.createInstance(LayerListDialog.java:88)
	at org.openstreetmap.josm.gui.MapFrame.<init>(MapFrame.java:175)
	at org.openstreetmap.josm.Main.addLayer(Main.java:239)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:157)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:90)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.Dialog$1.run(Unknown Source)
	at java.awt.Dialog$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by mjulius

Owner: changed from team to anonymous
Status: newneedinfo

Can you reproduce this with current josm-latest?

comment:2 Changed 9 years ago by mjulius

Resolution: worksforme
Status: needinfoclosed

There was no reply.

comment:3 Changed 8 years ago by Don-vip

Description: modified (diff)

Ticket #6473 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by Don-vip

Cc: dcp added

Ticket #6713 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by Don-vip

Ticket #7407 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by Don-vip

Resolution: worksforme
Status: closedreopened

Looks like this problem is still present as it occurred with r4961 (see #7407).

comment:7 Changed 7 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

In 5262/josm:

fixed #6004 - Dialog was already created exeception

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.