Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6001 closed defect (duplicate)

Unable to add Bing imagery layer

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Add Bing imagery layer.

What is the expected result?
Imagery layer is added to Layers dialog; Imagery tiles are loaded and shown.

What happens instead?
Unexpected Exception dialog is shown.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-02-20 02:31:40
Last Changed Author: jttt
Revision: 3915
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-02-19 19:38:10 +0100 (Sat, 19 Feb 2011)
Last Changed Rev: 3915

Identification: JOSM/1.5 (3915 en)
Memory Usage: 494 MB / 494 MB (352 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Plugin: FixAddresses (25374)
Plugin: OpeningHoursEditor (25190)
Plugin: PicLayer (25219)
Plugin: RoadSigns (25192)
Plugin: buildings_tools (25192)
Plugin: contourmerge (25200)
Plugin: download_along (25190)
Plugin: editgpx (25192)
Plugin: imageryadjust (25199)
Plugin: lakewalker (25192)
Plugin: livegps (25192)
Plugin: mapdust (25312)
Plugin: mappinonosm (5)
Plugin: openstreetbugs (25199)
Plugin: openvisible (25192)
Plugin: public_transport (25192)
Plugin: reverter (25190)
Plugin: routing (25199)
Plugin: turnrestrictions (25199)
Plugin: undelete (25199)
Plugin: utilsplugin2 (25190)
Plugin: walkingpapers (25191)
Plugin: waydownloader (25190)

java.lang.IllegalArgumentException: input == null!
	at javax.imageio.ImageIO.read(Unknown Source)
	at org.openstreetmap.gui.jmapviewer.tilesources.BingAerialTileSource.getAttributionImage(BingAerialTileSource.java:162)
	at org.openstreetmap.josm.gui.layer.TMSLayer.initTileSource(TMSLayer.java:251)
	at org.openstreetmap.josm.gui.layer.TMSLayer.<init>(TMSLayer.java:323)
	

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Ldp

r3915 from josm.openstreetmap.org crashes as above. A self-compiled r3915 doesn't crash.

comment:2 Changed 7 years ago by scai

same problem here

comment:3 Changed 7 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:4 Changed 7 years ago by stoecker

Closed as duplicate of #5993.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.