Modify

Opened 10 years ago

Closed 10 years ago

#5975 closed defect (fixed)

Wrong plugin reported in error report

Reported by: cmuelle8 Owned by: team
Priority: minor Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. start josm
  2. download a region of data
  3. before the map displays, elevation profile plugin throws an error

What is the expected result?

elevation profile does not throw an error

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Build-Date: 2011-02-17 02:17:39
Revision: 3908
Is-Local-Build: true

Identification: JOSM/1.5 (3908 SVN de)
Memory Usage: 247 MB / 3569 MB (86 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux

Plugin: AddrInterpolation (25199)
Plugin: CommandLine (25200)
Plugin: DirectUpload (25199)
Plugin: ElevationProfile (25192)
Plugin: OpeningHoursEditor (25190)
Plugin: PicLayer (25219)
Plugin: RoadSigns (25192)
Plugin: SimplifyArea (25192)
Plugin: alignways (25199)
Plugin: buildings_tools (25192)
Plugin: colorscheme (25192)
Plugin: contourmerge (25200)
Plugin: dataimport (25192)
Plugin: download_along (25190)
Plugin: editgpx (25192)
Plugin: junctionchecking (82)
Plugin: lakewalker (25192)
Plugin: livegps (25192)
Plugin: mapdust (25312)
Plugin: measurement (25199)
Plugin: openstreetbugs (25199)
Plugin: openvisible (25192)
Plugin: pdfimport (25260)
Plugin: photo_geotagging (25199)
Plugin: public_transport (25192)
Plugin: restart (25199)
Plugin: reverter (25190)
Plugin: routes (25199)
Plugin: routing (25199)
Plugin: terracer (25199)
Plugin: turnrestrictions (25199)
Plugin: waydownloader (25190)
Plugin: waypoint_search (25191)
Plugin: wayselector (25191)

org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin ElevationProfile aufgetreten.
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:32)
	at org.openstreetmap.josm.plugins.PluginHandler.notifyMapFrameChanged(PluginHandler.java:840)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:193)
	at org.openstreetmap.josm.Main.addLayer(Main.java:244)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:157)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:90)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
	at java.awt.Dialog$1.run(Dialog.java:1046)
	at java.awt.Dialog$3.run(Dialog.java:1098)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1096)
	at java.awt.Component.show(Component.java:1563)
	at java.awt.Component.setVisible(Component.java:1515)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:986)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:29)
	... 27 more
Caused by: java.lang.IncompatibleClassChangeError: Expecting non-static method org.openstreetmap.josm.plugins.fixAddresses.FixUnresolvedStreetsAction.getCurrentDataSet()Lorg/openstreetmap/josm/data/osm/DataSet;
	at org.openstreetmap.josm.plugins.fixAddresses.FixUnresolvedStreetsAction.updateEnabledState(FixUnresolvedStreetsAction.java:74)
	at org.openstreetmap.josm.actions.JosmAction$LayerChangeAdapter.layerAdded(JosmAction.java:201)
	at org.openstreetmap.josm.gui.MapView.fireLayerAdded(MapView.java:146)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:281)
	at org.openstreetmap.josm.Main.addLayer(Main.java:253)
	at org.openstreetmap.josm.plugins.elevation.ElevationProfilePlugin.getCurrentLayer(ElevationProfilePlugin.java:87)
	at org.openstreetmap.josm.plugins.elevation.ElevationProfilePlugin.mapFrameInitialized(ElevationProfilePlugin.java:75)
	... 32 more

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by bastiK

First of all: It's somewhat risky to have that many plugins installed. It can have impact on performance and stability. In a productive environment I would disable unused plugins.

Then the plugin that causes the crash is fixAddresses, which isn't even in the list. Can you investigate this, e.g. is this plugin in your preference file and does it show some warning on the console?

Generally, plugin update might help.

comment:2 Changed 10 years ago by cmuelle8

Resolution: fixed
Status: newclosed

Thanks, josm needed a restart. It suggested to disable fixAdresses before the error. Weird though, that josm states that the error would be caused by "ElevationProfile"..

Thanks for your support.

Christian

comment:3 Changed 10 years ago by stoecker

Priority: normalminor
Resolution: fixed
Status: closedreopened
Summary: [ElevationProfile] errorWrong plugin reported in error report

It says so, because both are involved and ElevationProfile starts with "e" and FixAddresses with "f". Maybe we should rather filter for all plugins and report the one which occurs first?

comment:4 Changed 10 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

In [4167/josm]:

fix #5975 - wrong plugin report in bug report

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.