Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5896 closed defect (duplicate)

josm hangs on start (current svn)

Reported by: Cobra Owned by: team
Priority: blocker Milestone:
Component: Core Version:
Keywords: Cc:

Description

This happens every time I try to start josm built from svn r3843...

The Java/josm process needs to be killed afterwards, it won't terminate.

java.lang.IncompatibleClassChangeError: Expecting non-static method org.openstreetmap.josm.actions.DownloadReferrersAction.getCurrentDataSet()Lorg/openstreetmap/josm/data/osm/DataSet;
	at org.openstreetmap.josm.actions.DownloadReferrersAction.updateEnabledState(DownloadReferrersAction.java:93)
	at org.openstreetmap.josm.actions.JosmAction.initEnabledState(JosmAction.java:160)
	at org.openstreetmap.josm.actions.JosmAction.installAdapters(JosmAction.java:149)
	at org.openstreetmap.josm.actions.JosmAction.<init>(JosmAction.java:93)
	at org.openstreetmap.josm.actions.JosmAction.<init>(JosmAction.java:68)
	at org.openstreetmap.josm.actions.DownloadReferrersAction.<init>(DownloadReferrersAction.java:29)
	at org.openstreetmap.josm.gui.MainMenu.<init>(MainMenu.java:113)
	at org.openstreetmap.josm.Main.<init>(Main.java:215)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:58)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:225)

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by stoecker

Resolution: duplicate
Status: newclosed

Do a clean and rebuild.

comment:2 Changed 11 years ago by stoecker

Closed as duplicate of #5888.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.