Modify

Opened 11 years ago

Closed 11 years ago

#5885 closed defect (fixed)

Going into Delete mode by pressing "d" doesn't change the Edit Toolbar

Reported by: andreas.perstinger@… Owned by: andreas.perstinger@…
Priority: minor Milestone:
Component: Core Version: tested
Keywords: delete key toolbar Cc:

Description

If I press the "d" key to change into the delete mode, the edit toolbar remains unchanged (last mode before delete stays gray). All other keys like "s", "a", "x", ... work fine.

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by GeorgFausB <news2@…>

This behaviour occurs only if previous the "DEL" key was pressed.
After that pressing the "d" key just changes the mode but not the GUI.

comment:2 Changed 11 years ago by stoecker

Owner: changed from team to andreas.perstinger@…
Status: newneedinfo

Can't reproduce. Please retest and provide a more detailed description.

comment:3 Changed 11 years ago by andreas.perstinger@…

As GeorgFaustB already said, it happens after the following steps:
If a start JOSM everything works fine. But after the first time I use the "DEL" key for deleting, pressing "d" for changing into delete-mode doesn't alter the toolbar on the left side. The cursor changes and deleting works, just the delete-button on the toolbar isn't selected (grey background colour)

I've also just tried the latest Version 3831 and the same behaviour happens:

I've opened a new session, added ("a") some nodes, went into select-mode ("s"), selected one node, deleted it ("d") -> cursor and toolbar changes accordingly.
After pressing "DEL" all other keys ("a", "s", "x", ...) change the cursor and the toolbar, "d" just changes the cursor but not the toolbar.

Hope that helps.

comment:4 Changed 11 years ago by stoecker

Resolution: fixed
Status: needinfoclosed

In [3835/josm]:

fix #5885

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain andreas.perstinger@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.