Modify

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5704 closed defect (fixed)

Mapdust plugin slows down zooming and panning

Reported by: Cobra Owned by: jBeata
Priority: normal Milestone:
Component: Plugin mapdust Version: latest
Keywords: Cc:

Description

When the mapdust plugin is installed, all zoom and pan operations are extremely slow. A simple pan in a not really densely mapped region takes 2 seconds, zoom even longer.

JOSM is unusable together with this plugin.

This happens with today's latest and all older revisions i tested.

Attachments (2)

mapdust.png (315.4 KB) - added by jBeata 9 years ago.
Route-Validation.osm (1.9 KB) - added by rickmastfan67 9 years ago.
This file will PROVE my point that the zoom problem is mapdust's problem and not JOSM's.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 9 years ago by jBeata

In what area/region did you test the MapDust plugin? What operating system do you use?
We did test the plugin in different areas and did work well without any zooming related problem. Also we didn't notice any zooming related problems.Also you need to use at least version 3592 of the JOSM editor for the MapDust plugin.

comment:2 Changed 9 years ago by jBeata

Priority: blockernormal

comment:3 Changed 9 years ago by Cobra

josm: r3697
OS: ubuntu 10.10

one area was this one, but even smaller areas showed these problems.

Bonus points for slowing josm down even without having been activated once.

comment:4 Changed 9 years ago by rickmastfan67

Priority: normalcritical

I'll add a comment on this as well. I've installed this plugin on my copy of JOSM as well and when zooming and panning is EXTREMELY slow even when zoomed in almost all the way when it should be extremely quick to respond since there is hardly anything to draw. I've tested this in several different areas and there is no change. No matter where I'm editing, JOSM is so slow it's annoying and almost unusable. When I deactivate the plugin completely and restart JOSM, the sluggish response goes away.

Windows 7 x64
JOSM 3697
Java 1.6.22 x64

Last edited 9 years ago by rickmastfan67 (previous) (diff)

Changed 9 years ago by jBeata

Attachment: mapdust.png added

comment:5 Changed 9 years ago by jBeata

The zooming problems are related to the JOSM editor not to the mapdust plugin. If the JOSM editor zooming works slow then definitely the mapdust plugin will work slow.

comment:6 Changed 9 years ago by jBeata

@Corba
See mapdust.png attached. I did test the plugin in your area and it works well, without any zooming problem.

comment:7 Changed 9 years ago by jBeata

Priority: criticalminor

Since there are some issues related to zooming for the JOSM editor , and this is not related to the MapDust plugin , the priority was changed to minor. The Plugin mapdust component is only for mapdust related bugs.

comment:7 Changed 9 years ago by rickmastfan67

Replying to jBeata:

The zooming problems are related to the JOSM editor not to the mapdust plugin. If the JOSM editor zooming works slow then definitely the mapdust plugin will work slow.

Sorry, but you're wrong here. This zooming/panning problem is all related to the mapdust plugin. I'm attaching a file here in a second that will prove this to you. You'll have to first deactivate mapdust (F12 and unlick it's box in the plugins menu and restart JOSM) and then pan/zoom around on the test file. You'll see that it's very fast because there is hardly anything there (because it's a test file) for JOSM to draw. Then reactivate mapdust and you'll see the extreme slowdown that mapdust causes when the plugin is active in JOSM on the same exact test file.

NOTE: I made this plugin for another bug so, ignore the name.

Changed 9 years ago by rickmastfan67

Attachment: Route-Validation.osm added

This file will PROVE my point that the zoom problem is mapdust's problem and not JOSM's.

comment:8 Changed 9 years ago by Cobra

josm is operating in normal speed. It's only slow when the mapdust plugin is enabled - even when there is no mapdust layer.

So it's definitely your problem - or you triggered a rare bug in josm.

comment:9 in reply to:  8 Changed 9 years ago by rickmastfan67

Priority: minorcritical

Replying to Cobra:

josm is operating in normal speed. It's only slow when the mapdust plugin is enabled - even when there is no mapdust layer.

So it's definitely your problem - or you triggered a rare bug in josm.

I agree with you Cobra. jBeata, there is a major problem here with the MapDust Plugin. Thus, I'm changing the priority again.

comment:10 Changed 9 years ago by jBeata

When the mapdust plugin is enabled ( you need to click on the mapdust icon shown on the left) and the mapdust layer is not showing yet, the plugin downloads the data from the MapDust service. In order to work as fast as possible you need to have a good internet connection, also the MapDust service should answer very quickly. I will investigate in more details next week this problem, to see exactly the time taken for each step ( MapDust service -> mapdust plugin, mapdust plugin -> draw on the map, and then compare between different operating systems, and so an...).
If there is a problem in our side, we will definitely find a solution and fix it, as soon as possible.

comment:11 Changed 9 years ago by rickmastfan67

Well, the problem here jBeata is that the slowdown happens even when the button on the left isn't clicked to fully activate MapDust. Just having it loaded (but not active) in JOSM will cause this crippling slowdown.

comment:12 Changed 9 years ago by jBeata

I did test you file and the MapDust bugs appears instantly in the JOSM editor, without any problem. I cannot reproduce your problem even with the uploaded file by Cobra.

comment:13 Changed 9 years ago by jBeata

In order to use the mapdust plugin you need to activate it by clicking on the icon on the left. If you did not click on the mapdust icon, then the layer was not activated, and there should not be any problem at all with the plugin.

comment:14 Changed 9 years ago by jBeata

Priority: criticalnormal

Since i cannot reproduce this issue i change the priority to normal. This is a performance issue and needs further testing.

comment:15 Changed 9 years ago by rickmastfan67

Replying to jBeata:

In order to use the mapdust plugin you need to activate it by clicking on the icon on the left. If you did not click on the mapdust icon, then the layer was not activated, and there should not be any problem at all with the plugin.

Well, that's where you're wrong. I've done several tests and it is all MapDust's problem. I've deactivated EVERY plugin I have for JOSM EXCEPT MapDust. Zooming and Panning with that test file that I attached in my copy of JOSM is still crippling slow, even when I don't activate the Mapdust layer.

When I then fully deactivate MapDust and run JOSM with NO Plugins, it runs with no problems. So, there is a problem with the MapDust plugin.

BTW jBeata, what OS are you running? Just curious.

comment:16 Changed 9 years ago by jBeata

Currently I did test at home on my laptop: Windows 7, 64x .

comment:17 Changed 9 years ago by Cobra

We know how to use it.

And yes, josm behaves like that only when mapdust is enabled but not yet active in any form besides showing the button.

All your other proposals can't be the cause: josm is working reasonably fast for me without mapdust (also without mapdust layer), my internet connection ist fast enough, ...

One point you should consider when looking into this: try to switch openGL support on/off.

My workaround for this issue is simple: deactivate this plugin. This is the only way to keep josm usable for me - that's why I triaged this as "blocker".

comment:18 Changed 9 years ago by jBeata

We will further investigate this issue. I will notify you about new information related to this problem as soon as possible.

comment:19 Changed 9 years ago by rickmastfan67

Just wanted to mention that this problem is still happening with the new version. I know that the new version was a fix for other things, but I just wanted you to know that the update didn't fix this by a freak chance.

comment:20 Changed 9 years ago by anonymous

This waring message is displayed at every zoom in/out, also in the case if you move the map, and there is no bug in the given area. A solution for this problem will be contained in the next release.(also this week)

comment:21 in reply to:  20 Changed 9 years ago by jBeata

Replying to anonymous:

This waring message is displayed at every zoom in/out, also in the case if you move the map, and there is no bug in the given area. A solution for this problem will be contained in the next release.(also this week)

This comment is not related to this issue. Under Windows the plugin works normally, and we did not reproduce any zooming/panning related issue. Under Linux this week will be investigated.

comment:22 Changed 9 years ago by jBeata

We did test the MapDust plugin under Linux environment, but we did not find any problem. The plugin works same as works on windows, without any problem. However next year we will do also some performance improvements.

comment:23 Changed 9 years ago by jBeata

This issue was added to the wishlist of the next MapDust JOSM plugin major release.

comment:24 Changed 9 years ago by jttt

Problem is in MapdustPlugin.zoomChanged. This method is called even when mapdust layer is not visible and it synchronously (in EDT thread) loads data from mapdust service.

Btw. why is ResourceBundle used in Configuration class? I would expected Properties there. I've tried to run the plugin directly in eclipse and it failed there because it didn't find mapdust_en_US file...

comment:25 in reply to:  24 Changed 8 years ago by anonymous

Replying to jttt:

Problem is in MapdustPlugin.zoomChanged. This method is called even when mapdust layer is not visible and it synchronously (in EDT thread) loads data from mapdust service.

Btw. why is ResourceBundle used in Configuration class? I would expected Properties there. I've tried to run the plugin directly in eclipse and it failed there because it didn't find mapdust_en_US file...

Any new modifications/update will be only next year after 10th January from our side (until then we are on holiday and there will be no update for the plugin). The Configuration class is used for reading the properties needed to connect to the MapDust service. Also the ResourceBoundle it is used in order to read some properties needed at runtime.
There is no need to modify any class from the service and util packages. In the future there will be added some other properties also. But at the moment this class will not be modified.
You need to use the build.xml file in order to build a new .jar for the plugin.
Also if you check out correctly the source files of the mapdust plugin it works correctly, without any problem!

comment:26 Changed 8 years ago by jBeata

This issue was already added to our list of priorities of next year. I will manage to solve this issue before the other issues/ new features and make an early update somewhere in January. ( Only after the 10th of January, because until then I am on holiday.)

comment:27 Changed 8 years ago by jBeata

The next MapDust JOSM release will contains some improvements for this issue. Also in order to work the plugin property a good internet connection is a must.

comment:28 Changed 8 years ago by jBeata

Resolution: fixed
Status: newclosed

There were some improvements related to the zooming/panning issues . These changes are contained in the new mapdust release: 25127 .

comment:29 Changed 8 years ago by rickmastfan67

Thank you for getting this fixed. I now no longer have the panning/zooming issues on my system even when the Mapdust plugin isn't activated. :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.