Modify

Opened 8 years ago

Closed 8 years ago

#5695 closed defect (fixed)

Warning "There is no MapDust Bug in your visible area" is shown twice

Reported by: kellerma Owned by: team
Priority: major Milestone:
Component: Plugin mapdust Version: latest
Keywords: MapDust Cc:

Description

After activation and downloading a some osm data the warning
message "There is no MapDust Bug in your visible area" is shown twice
and after that after every panning.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-02 02:31:24
Last Changed Author: bastiK
Revision: 3690
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-01 14:02:38 +0100 (Wed, 01 Dec 2010)
Last Changed Rev: 3690

Identification: JOSM/1.5 (3690 de)
Memory Usage: 66 MB / 247 MB (25 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: imagery (24541)
Plugin: mapdust (24514)

Attachments (0)

Change History (19)

comment:1 Changed 8 years ago by jBeata

An improvement for this issue will contained in the next MapDust JOSM plugin release.

comment:2 Changed 8 years ago by bastiK

Ticket #5739 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by jBeata

Fixed in mapdust version: 24821 .

comment:4 Changed 8 years ago by jBeata

Resolution: fixed
Status: newclosed

comment:5 Changed 8 years ago by kellerma

Resolution: fixed
Status: closedreopened

Hello,

the bug still exists in the newest version.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-17 02:31:34
Last Changed Author: bastiK
Revision: 3730
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-16 18:20:22 +0100 (Thu, 16 Dec 2010)
Last Changed Rev: 3730

Identification: JOSM/1.5 (3730 de)
Memory Usage: 52 MB / 481 MB (12 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: mapdust (24821)
Plugin: osmarender (22765)

comment:6 Changed 8 years ago by jBeata

We cannot reproduce this bug anymore.

comment:7 Changed 8 years ago by jBeata

The plugin works as follows: if you move the map to an area with no bugs the warning will be shown. If you move the map to another area with no bugs also the warning will be shown. Basically this warning is shown whenever you move your map to an area with no bugs. This is how the plugin works.
This was tested on Windows and also on Linux OS.

comment:8 in reply to:  5 Changed 8 years ago by jBeata

Replying to kellerma:

Hello,

the bug still exists in the newest version.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-17 02:31:34
Last Changed Author: bastiK
Revision: 3730
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-16 18:20:22 +0100 (Thu, 16 Dec 2010)
Last Changed Rev: 3730

Identification: JOSM/1.5 (3730 de)
Memory Usage: 52 MB / 481 MB (12 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: mapdust (24821)
Plugin: osmarender (22765)

Since I cannot reproduce now this anymore (on my home computer), I will try to reproduce tomorrow at work this issue. If i will find any problem I will fix it tomorrow. In the case if we cannot reproduce this issue will be added to next year whislist containing the improvements/new features of the mapdust plugin.

comment:9 in reply to:  7 ; Changed 8 years ago by bastiK

Replying to jBeata:

The plugin works as follows: if you move the map to an area with no bugs the warning will be shown. If you move the map to another area with no bugs also the warning will be shown. Basically this warning is shown whenever you move your map to an area with no bugs.
This is how the plugin works.

The problem is, that the warning comes over and over again. When I try to zoom to an area that has bugs, it bocks this attempt by showing this modal dialog. After each tiny movement you have to press OK. My suggestion: You could show this message in the map dust bug reports area (lower right). Maybe show the dialog once, to make the user aware of the issue.

comment:10 Changed 8 years ago by jBeata

Currently the plugin works as you described: if in the new area it no bug the warning message is shown; when you move to a new area and there is again no bug the warning message will be again shown. As an improvement I will consider your suggestions.
A solution for this issue will be submitted next year.

comment:11 in reply to:  9 Changed 8 years ago by jBeata

Replying to bastiK:

Replying to jBeata:

The plugin works as follows: if you move the map to an area with no bugs the warning will be shown. If you move the map to another area with no bugs also the warning will be shown. Basically this warning is shown whenever you move your map to an area with no bugs.
This is how the plugin works.

The problem is, that the warning comes over and over again. When I try to zoom to an area that has bugs, it bocks this attempt by showing this modal dialog. After each tiny movement you have to press OK. My suggestion: You could show this message in the map dust bug reports area (lower right). Maybe show the dialog once, to make the user aware of the issue.

Your suggestion was added to the wishlist of the next MapDust JOSM plugin major release.

comment:12 Changed 8 years ago by ch70

Yes, please rethink this "feature" - it's really annoying to get this message with every move or change of the zoom. I would rather prefer the way the openstreetbugs plugin works (=no message at all).

Moreover, if the plugin is active, current visible bugs are listed in the mapdust window and if no bug is visible the list is empty (or should be - I cannot check it right now because the mapdust service is unavailable) - that's enough in my opinion, so I don't see a reason to get a popup in addition.

comment:13 Changed 8 years ago by ch70

Check also ticket #5798 that I've just opened - might be related.

comment:14 in reply to:  13 Changed 8 years ago by anonymous

Replying to ch70:

Check also ticket #5798 that I've just opened - might be related.

Aprox. the same issue.

comment:15 Changed 8 years ago by RussNelson

Priority: minorblocker

This plugin is useless with this bug. Popping up a message to say that there are no bugs is itself a bug. There is no point in doing it because I can see from a glance at the bug window that it's empty.

comment:16 Changed 8 years ago by jBeata

Priority: blockermajor

Solving this is in progress. The first version of the plugin was implemented in the following way: If there is no bug in your area the warning message will pop up. For the next release this issue will be removed.
Until then changing the priority to major, since we are working already on removing this issue.

comment:17 Changed 8 years ago by ch70

Please check #5798 too - it seems that the plugin tries to contact the Mapdust site in the background even when not activated (so I had to uninstall it to get JOSM to work again).

comment:18 in reply to:  17 Changed 8 years ago by jBeata

Replying to ch70:

Please check #5798 too - it seems that the plugin tries to contact the Mapdust site in the background even when not activated (so I had to uninstall it to get JOSM to work again).

Both these problems will be resolved with the next MapDust release.

comment:19 Changed 8 years ago by jBeata

Resolution: fixed
Status: reopenedclosed

This message will not be shown anymore. If there is no bug in the given area, then the bugs list will contains the following message: " No bugs in the current view".
The fixed version of the mapdust plugin is: 25127 .

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.