Modify

Opened 11 years ago

Closed 11 years ago

#5671 closed defect (fixed)

Button to toggle visible state on the layer name line, unexpected behaviour

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: visibility toggle button Cc:

Description

When I alter the visibility state of a layer by first selecting the layer name in the list of loaded layers and then pressing the visibility toggle button (the big button on the button bar), and then press the "delete" key, then the selection of the active layer is deleted. This is also what I expect.

Instead, if I alter the visibility state of a layer by pressing the small toggle button (eye icon) which is displayed next to the layer name in the list of loaded layers, and then press the "delete" key, the layer for which I altered the visibility state is deleted (instead of the selection in the active layer). This is unexpected and unwanted, as I never intended to select that layer, only to alter its visibility state.

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

In [3680/josm]:

fixed #5671 - remove shortcut 'd' to delete layer in layerlist as it collided too often with mapmode delete 'd'

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.