Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5636 closed defect (fixed)

Can't fully PURGE some boundary:administrative ways

Reported by: rickmastfan67 Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: purge Cc:

Description

Problem:

Can't fully purge any boundary:administrative ways. If I try, only the way can be purged and none of the nodes can be.

Steps to reproduce:

  1. Download any boundary:administrative way. (Example: Download way 24315722)
  2. Once loaded, select the way on the screen.
  3. Ctrl-Shift-P to purge the way.
  4. Normally, if you select any other way to Purge, the nodes of it are also selected. But in this case, NO nodes are selected. And there is no option to even select the nodes like on other ways.
  5. Hit the Purge button.

Result:

All the nodes that were part of the boundary:administrative way are still there while the way itself is gone.

Attachments (0)

Change History (6)

comment:1 Changed 12 years ago by rickmastfan67

Well, after some more testing, it doesn't effect all "boundary:administrative" ways since I was able to purge "Way 40650645" which is also an administrative way with no problems.

So, it might have something to do with the "border_type:county" tag. I don't know. All I know is that there is I can't purge some "boundary:administrative" ways. Maybe because the nodes have tags on them for "Way 24315722"? Who knows. :/

So, I'm at a lost here what could be the defacto reason for not being able to purge the way in the original report. Hopefully you guys will be able to figure it out so it can be fixed soon. Because IMO, being able to purge those "boundary:administrative" ways would be nice, especially when you don't want to have to worry about accidentally connecting a way your making to one of them.

comment:2 Changed 12 years ago by rickmastfan67

Summary: Can't fully PURGE any boundary:administrative waysCan't fully PURGE some boundary:administrative ways

comment:3 Changed 12 years ago by bastiK

Resolution: fixed
Status: newclosed

In [3657/josm]:

fixed #5636 - Can't fully PURGE some boundary:administrative ways (added new uninteresting key)

comment:4 Changed 12 years ago by bastiK

Note, that you should better use the Filter feature for this.

comment:5 in reply to:  4 Changed 12 years ago by rickmastfan67

Replying to bastiK:

Note, that you should better use the Filter feature for this.

Are you talking about selecting a way and then doing "Ctrl+F" and then in the search box have "type:node" and "find in selection"? If you are, that doesn't work. (If you want me to create a bug report for that, let me know and I'll make a separate report for it.)

==

Anyways, thanks for making the tweak in 3657 to allow doing the purge correctly. :)

comment:6 Changed 12 years ago by bastiK

Filter is the gray hopper symbol to the left.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.